From 5e20ba9726b1fe309ca89b5bd375312791c238fc Mon Sep 17 00:00:00 2001 From: Fridolin Somers Date: Thu, 2 Dec 2021 12:21:45 -1000 Subject: [PATCH] Bug 29625: Fix var name in Koha::BiblioUtils get_all_biblios_iterator In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. Test plan : 1) Run Elasticsearch full rebuild with and without patch 2) Check all biblio records are in index --- Koha/BiblioUtils.pm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Koha/BiblioUtils.pm b/Koha/BiblioUtils.pm index 1ece4a8317..04e7977a1d 100644 --- a/Koha/BiblioUtils.pm +++ b/Koha/BiblioUtils.pm @@ -123,7 +123,7 @@ records instead of all. =cut sub get_all_biblios_iterator { - my ($self, %options) = @_; + my ($class, %options) = @_; my $search_terms = {}; my ($slice_modulo, $slice_count); -- 2.34.0