From 7ce7050bc32d26b962c36cc9642bb662cdd16b76 Mon Sep 17 00:00:00 2001 From: Fridolin Somers Date: Thu, 2 Dec 2021 12:21:45 -1000 Subject: [PATCH] Bug 29625: Fix var name in Koha::BiblioUtils get_all_biblios_iterator In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. Test plan : 1) Run Elasticsearch full rebuild with and without patch 2) Check all biblio records are in index Signed-off-by: Michal Denar Signed-off-by: Jonathan Druart --- Koha/BiblioUtils.pm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/Koha/BiblioUtils.pm b/Koha/BiblioUtils.pm index 1ece4a8317b..8301210de48 100644 --- a/Koha/BiblioUtils.pm +++ b/Koha/BiblioUtils.pm @@ -123,7 +123,7 @@ records instead of all. =cut sub get_all_biblios_iterator { - my ($self, %options) = @_; + my ($class, %options) = @_; my $search_terms = {}; my ($slice_modulo, $slice_count); @@ -153,7 +153,7 @@ sub get_all_biblios_iterator { biblionumber => $row->biblionumber, embed_items => 1 }); my $next = eval { - __PACKAGE__->new($marc, $row->biblionumber); + $class->new($marc, $row->biblionumber); }; if ($@) { warn "Something went wrong reading record for biblio $row->biblionumber: $@\n"; -- 2.25.1