From 9ab3759a649513d28baff0f58816c382872a0eea Mon Sep 17 00:00:00 2001 From: Jonathan Druart Date: Tue, 14 Jun 2016 11:18:32 +0100 Subject: [PATCH] Bug 16717: Improve variable naming $category was a categorycode, to help the readability it's better to name it $categorycode or assign a Category to $category Signed-off-by: Jonathan Druart --- t/db_dependent/Holds.t | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/t/db_dependent/Holds.t b/t/db_dependent/Holds.t index b368481..f9ddc46 100755 --- a/t/db_dependent/Holds.t +++ b/t/db_dependent/Holds.t @@ -34,7 +34,7 @@ my $dbh = C4::Context->dbh; my $branch_1 = $builder->build({ source => 'Branch' })->{ branchcode }; my $branch_2 = $builder->build({ source => 'Branch' })->{ branchcode }; -my $category = $builder->build({ source => 'Category' })->{categorycode}; +my $category = $builder->build({ source => 'Category' }); my $borrowers_count = 5; @@ -60,7 +60,7 @@ foreach (1..$borrowers_count) { my $borrowernumber = AddMember( firstname => 'my firstname', surname => 'my surname ' . $_, - categorycode => $category, + categorycode => $category->{categorycode}, branchcode => $branch_1, ); push @borrowernumbers, $borrowernumber; -- 2.8.1