Bug 10294

Summary: when the word "user" is included in default in framework, surname of login creating record inserted
Product: Koha Reporter: David Noe <drnoe>
Component: CatalogingAssignee: Galen Charlton <gmcharlt>
Status: RESOLVED DUPLICATE QA Contact:
Severity: normal    
Priority: P5 - low CC: jonathan.druart+koha, katrin.fischer, m.de.rooy, nengard, rocio, veron
Version: master   
Hardware: All   
OS: All   
See Also: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7045
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14941
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:

Description David Noe 2013-05-20 20:55:19 UTC
When the word "user" is included in a default value in a MARC subfield structure of a tag in a framework, the  surname of he user login creating record is inserted in the place of the word "user."

Create the deafualt value in the framework
-In MARC frameworks.
-Select a MARC structure of any framework to edit.
-Select the subfields to edit.
-Select the Edit Subfields button.
-Select Display more constraints of any subfield tab.
-Include "user" in the default value.
(make sure hidden is st to 0).
-Save Changes.


Create a new record
-In Cataloging, select New Record with the edited framework 
-Go to the tag with the default value.
-The surname of the user with which you create the new record will be in the tag in the place of user.
Comment 1 Katrin Fischer 2013-05-20 22:35:20 UTC
Hm I am not sure user = surname makes sense to me - what if you have more than one staff member with the same surname? and why not use surname as the keyword?
I think for 'user' i would expect the username (opac login) to be inserted in the record.
Comment 2 Nicole C. Engard 2013-05-21 11:08:20 UTC
I think that this is related to http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7045
Comment 3 Rocio Dressler 2016-04-29 16:43:59 UTC
Hello, this is still an issue for libraries. We would like to be able to use the actual text "user" without it transforming into the surname of the librarian modifying the record.
Comment 4 Jonathan Druart 2016-08-16 08:22:52 UTC
(In reply to Rocio Dressler from comment #3)
> Hello, this is still an issue for libraries. We would like to be able to use
> the actual text "user" without it transforming into the surname of the
> librarian modifying the record.

Will be fixed by the patch I have just submitted on bug 7045.

*** This bug has been marked as a duplicate of bug 7045 ***