Bug 11240

Summary: Adding a restriction does not save the date
Product: Koha Reporter: Chris Cormack <chris>
Component: PatronsAssignee: Bugs List <koha-bugs>
Status: CLOSED FIXED QA Contact: Testopia <testopia>
Severity: major    
Priority: P5 - low CC: gmcharlt, kyle.m.hall
Version: master   
Hardware: All   
OS: All   
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:
Bug Depends on: 11216    
Bug Blocks:    
Attachments: Bug 11240 : Date of restriction not saved on Patron Edit screen
Bug 11240 : Date of restriction not saved on Patron Edit screen
[PASSED-QA] Bug 11240 : Date of restriction not saved on Patron Edit screen

Description Chris Cormack 2013-11-12 21:35:56 UTC

    
Comment 1 Chris Cormack 2013-11-12 21:36:32 UTC
If you add an exception on the edit patron page, the date is either not saved correctly, or not displayed correctly
Comment 2 Chris Cormack 2013-11-12 22:07:39 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-11-13 08:57:56 UTC Comment hidden (obsolete)
Comment 4 Galen Charlton 2013-11-14 19:11:31 UTC
For the sake of having a keyword: manual restriction.
Comment 5 Brendan Gallagher 2013-11-14 19:36:06 UTC
Created attachment 22947 [details] [review]
[PASSED-QA] Bug 11240 : Date of restriction not saved on Patron Edit screen

To test:

1/ Edit a patron
2/ Add a restriction with a date (in any format other than iso)
3/ Not the date is not saved
4/ Apply patch
5/ Add restriction again, note it is saved

The problem is output_pref was being called with the wrong parameters

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Note: The issue in on the memberentry form only (not the restriction
form on the check out page).

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>
Comment 6 Galen Charlton 2013-11-14 23:08:42 UTC
Pushed to master and 3.14.x.  Thanks, Chris!