Bug 15388

Summary: Show Syndetics covers by UPC in search results
Product: Koha Reporter: Ed Veal <eveal>
Component: OPACAssignee: Nick Clemens <nick>
Status: CLOSED FIXED QA Contact: Testopia <testopia>
Severity: enhancement    
Priority: P5 - low CC: brendan, cbrannon, frederic, kyle, martin.renvoize, nick, rkuiper
Version: master   
Hardware: All   
OS: All   
Change sponsored?: --- Patch complexity: Trivial patch
Documentation contact: Documentation submission:
Text to go in the release notes:
If Syndetics covers is active, now the system send to Syndetics UPCs or OCLC numbers if the records doesn't have ISBN. This true espacialy for DVD. You can see the improvment in results and in record display.
Version(s) released in:
Attachments: Bug 15388 - Show Syndetics covers by UPC in search results
[SIGNED-OFF] Bug 15388 - Show Syndetics covers by UPC in search results
[PASSED QA] Bug 15388 - Show Syndetics covers by UPC in search results

Description Ed Veal 2015-12-16 21:53:59 UTC
If an video has a UPC but not an ISBN the cover art does not show on the results page. the UPC code is used to present the cover art on the details page but not the results page. 

Ed
Comment 1 Nick Clemens 2016-08-26 19:26:31 UTC Comment hidden (obsolete)
Comment 2 Nick Clemens 2016-08-30 10:41:44 UTC
Created attachment 55007 [details] [review]
[SIGNED-OFF] Bug 15388 - Show Syndetics covers by UPC in search results

Syndetics code accepts UPC and OCLC numbers, however, we were only passing this if there
was an ISBN. This patch alters the code to search if either an ISBN or
UPC is present

To test:
Enable syndetics (will need an account)
Search for items with UPCs or OCLC numbers and no ISBN (DVDs)
Note there are no images in search results but there are in details
Apply patch
Note that items with images in details now also have images in results

Signed-off-by: Barbara.Johnson@bedfordtx.gov
Comment 3 Christopher Brannon 2016-10-12 14:38:49 UTC
Would like to see this QA'd.  We're running into this problem.
Comment 4 Martin Renvoize 2016-10-13 09:32:54 UTC
Created attachment 56315 [details] [review]
[PASSED QA] Bug 15388 - Show Syndetics covers by UPC in search results

Syndetics code accepts UPC and OCLC numbers, however, we were only passing this if there
was an ISBN. This patch alters the code to search if either an ISBN or
UPC is present

To test:
Enable syndetics (will need an account)
Search for items with UPCs or OCLC numbers and no ISBN (DVDs)
Note there are no images in search results but there are in details
Apply patch
Note that items with images in details now also have images in results

Signed-off-by: Barbara.Johnson@bedfordtx.gov

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 5 Martin Renvoize 2016-10-13 09:33:48 UTC
Minor change, all works as expected, no breakage.
Comment 6 Brendan Gallagher 2016-10-13 15:39:17 UTC
Pushed to Master - Should be in the November 16.11 Release.  Thanks!
Comment 7 Christopher Brannon 2016-10-13 16:16:14 UTC
Can this be ported to 3.22?
Comment 8 Rhonda Kuiper 2016-10-13 16:52:15 UTC
I second Christopher's request to port this fix to 3.22.
Comment 9 Katrin Fischer 2016-10-16 11:43:58 UTC
*** Bug 12420 has been marked as a duplicate of this bug. ***
Comment 10 Frédéric Demians 2016-10-22 12:19:53 UTC
Pushed in 16.05. Will be in 16.05.05.