Bug 16870

Summary: Koha::Issue(s) should be named Koha::Checkout(s)
Product: Koha Reporter: Kyle M Hall <kyle>
Component: CirculationAssignee: Kyle M Hall <kyle>
Status: RESOLVED DUPLICATE QA Contact: Testopia <testopia>
Severity: enhancement    
Priority: P5 - low CC: gmcharlt, jonathan.druart+koha, kyle.m.hall, srdjan
Version: master   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17796
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:
Bug Depends on: 6906, 16086    
Bug Blocks:    
Attachments: Bug 16870 - Move and rename class files and unit tests
Bug 16870 - Update Koha::Patron use of the class
Bug 16870 - Move and rename class files and unit tests
Bug 16870 - Update Koha::Patron use of the class
Bug 16870 - Move and rename class files and unit tests
Bug 16870 - Update Koha::Patron use of the class
[SIGNED-OFF] Bug 16870 - Move and rename class files and unit tests
[SIGNED-OFF] Bug 16870 - Update Koha::Patron use of the class

Description Kyle M Hall 2016-07-07 14:26:05 UTC
By our naming guidelines, the term "issue" is deprecated in favor of "checkout". We should update the class names to match.
Comment 1 Kyle M Hall 2016-07-07 16:14:59 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2016-07-07 16:16:28 UTC Comment hidden (obsolete)
Comment 3 Srdjan Jankovic 2016-07-13 06:00:57 UTC
Kyle, Koha::Checkout(s) was added in 14757, patch 1 https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=52924
Comment 4 Kyle M Hall 2016-07-13 13:06:58 UTC
(In reply to Srdjan Jankovic from comment #3)
> Kyle, Koha::Checkout(s) was added in 14757, patch 1
> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=52924

Yes, I noticed that! I will need to modify this patch set to take that into account.
Comment 5 Kyle M Hall 2016-07-13 13:51:16 UTC Comment hidden (obsolete)
Comment 6 Kyle M Hall 2016-07-13 13:51:23 UTC Comment hidden (obsolete)
Comment 7 Kyle M Hall 2016-07-13 13:55:12 UTC Comment hidden (obsolete)
Comment 8 Kyle M Hall 2016-07-13 13:55:18 UTC Comment hidden (obsolete)
Comment 9 Srdjan Jankovic 2016-07-15 02:20:52 UTC
Created attachment 53407 [details] [review]
[SIGNED-OFF] Bug 16870 - Move and rename class files and unit tests

Signed-off-by: Srdjan <srdjan@catalyst.net.nz>
Comment 10 Srdjan Jankovic 2016-07-15 02:22:24 UTC
Created attachment 53408 [details] [review]
[SIGNED-OFF] Bug 16870 - Update Koha::Patron use of the class

Test Plan:
1) Apply this patch
2) prove t/db_dependent/Patron/Borrower_PrevCheckout.t
3) prove t/db_dependent/Koha/Checkouts.t

Signed-off-by: Srdjan <srdjan@catalyst.net.nz>
Comment 11 Jonathan Druart 2016-07-15 12:52:48 UTC
Should not we rename OldIssue[s] as well?
Comment 12 Jonathan Druart 2017-01-17 07:47:49 UTC

*** This bug has been marked as a duplicate of bug 17796 ***