Bug 21297

Summary: "More lists" screen missing "Select an Existing list" fieldset when all lists are public
Product: Koha Reporter: Barton Chittenden <barton>
Component: ListsAssignee: Jonathan Druart <jonathan.druart>
Status: RESOLVED FIXED QA Contact: Testopia <testopia>
Severity: normal    
Priority: P5 - low CC: arattler, caroline.cyr-la-rose, fridolin.somers, jonathan.druart, julian.maurice, katrin.fischer, m.de.rooy, martin.renvoize, nick
Version: master   
Hardware: All   
OS: All   
Change sponsored?: --- Patch complexity: ---
Who signed the patch off: Text to go in the release notes:
Version(s) released in:
Bug Depends on: 17886    
Bug Blocks:    
Attachments: Bug 21297: Display public lists to existing lists when adding a new item
Bug 21297: Display public lists to existing lists when adding a new item

Description Barton Chittenden 2018-08-30 22:54:38 UTC
When creating lists from the staff search results page, clicking 'More Lists' launches cgi-bin/koha/virtualshelves/addbybiblionumber.pl in a new window.

If the existing lists are all public, only the 'Add to a new list' fieldset is visable.

If a private list is added, the 'Select an existing list' fieldset comes in to view.

---

To re-create:

Start with an account that has no private lists defined. 

1) Add 10 public lists (This is when the 'More lists' menu item becomes view-able)
2) Select an item
3) Click Add to list
4) Select 'More Lists' menu item
5) Note that 'Select an existing list' is not an available option

Add a private list, then repeat steps 2-4, note that 'Select an existing list' now shows on the 'Add to a list' page.
Comment 1 Jonathan Druart 2018-09-14 22:56:41 UTC
Caused by
  commit c089df3f3b45782516b63d22c34bc265c667dd35
  Bug 17886: Don't show option to add to existing list if there are no lists
Comment 2 Jonathan Druart 2018-09-14 22:59:00 UTC
Created attachment 78829 [details] [review]
Bug 21297: Display public lists to existing lists when adding a new item

If there are no private lists the public lists are not displayed.

Test plan:
1) Add 10 public lists (This is when the 'More lists' menu item becomes
view-able)
2) Select an item
3) Click Add to list
4) Select 'More Lists' menu item
5) Note that 'Select an existing list' is an available option
Comment 3 Jonathan Druart 2018-09-14 22:59:27 UTC
Note for QA: The logic is correct OPAC side.
Comment 4 Caroline Cyr La Rose 2018-09-16 17:02:50 UTC
The test should say add *more than* 10 lists. The "More lists" option only appeared after I added my 11th list.

But otherwise, the patch works :)
Comment 5 Julian Maurice 2018-09-24 10:33:13 UTC
Created attachment 79292 [details] [review]
Bug 21297: Display public lists to existing lists when adding a new item

If there are no private lists the public lists are not displayed.

Test plan:
1) Add 10 public lists (This is when the 'More lists' menu item becomes
view-able)
2) Select an item
3) Click Add to list
4) Select 'More Lists' menu item
5) Note that 'Select an existing list' is an available option

Signed-off-by: Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com>
Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 6 Nick Clemens 2018-09-28 19:54:10 UTC
Awesome work all!

Pushed to master for 18.11
Comment 7 Martin Renvoize 2018-10-03 09:19:31 UTC
Pushed to 18.05.x for 18.05.05.
Comment 8 Fridolin SOMERS 2018-10-08 06:11:10 UTC
Pushed to 17.11.x for 17.11.11
Comment 9 Katrin Fischer 2018-10-12 18:50:21 UTC
*** Bug 21566 has been marked as a duplicate of this bug. ***