Bug 22157

Summary: HideLostItems items still show in OPAC when patron places a hold on a specific item
Product: Koha Reporter: Kelly McElligott <kelly>
Component: OPACAssignee: Bugs List <koha-bugs>
Status: RESOLVED DUPLICATE QA Contact: Testopia <testopia>
Severity: normal    
Priority: P5 - low CC: katrin.fischer, lisettepalouse+koha, nick
Version: master   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15448
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:

Description Kelly McElligott 2019-01-17 18:06:48 UTC
If a library has the system preference set to HIDE lost items, the item will still show up in the holds screen when a patron places a hold on a specific item
These items should not appear within the OPAC as they should be hidden per this system preference.

This bug is similar to 15448 where the system preference OPAChiddenItems is performing the same way. This might have some correlation with bug 2711.
Comment 1 Katrin Fischer 2019-08-18 08:16:36 UTC
Confirmed on master, item is hidden from the detail view, but reappears when placing a hold. Placing holds is blocked correctly.
Comment 2 Nick Clemens 2022-01-14 14:58:02 UTC
Fixed by bug 24254

*** This bug has been marked as a duplicate of bug 24254 ***