Bug 22721

Summary: Normalize GetMarcFromKohaField calls
Product: Koha Reporter: Josef Moravec <josef.moravec>
Component: Architecture, internals, and plumbingAssignee: Josef Moravec <josef.moravec>
Status: RESOLVED FIXED QA Contact: Katrin Fischer <katrin.fischer>
Severity: enhancement    
Priority: P5 - low CC: black23, dpavlin, fridolin.somers, katrin.fischer, m.de.rooy, martin.renvoize, mtompset, tomascohen
Version: master   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21172
Change sponsored?: --- Patch complexity: Medium patch
Who signed the patch off: Text to go in the release notes:
Version(s) released in:
19.11.00
Bug Depends on: 19096    
Bug Blocks: 19097, 23247    
Attachments: Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls

Description Josef Moravec 2019-04-17 05:55:46 UTC

    
Comment 1 Josef Moravec 2019-04-17 06:14:26 UTC
Created attachment 88137 [details] [review]
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls

Test plan:
Run tests, at least:
    t/db_dependent/Biblio.t
    t/db_dependent/Biblio/TransformHtmlToMarc.t
    t/db_dependent/Charset.t
    t/db_dependent/Circulation/GetTopIssues.t
    t/db_dependent/Filter_MARC_ViewPolicy.t
    t/db_dependent/ImportBatch.t
    t/db_dependent/Items.t
    t/db_dependent/Items/AutomaticItemModificationByAge.t
    t/db_dependent/Items/GetItemsForInventory.t
    t/db_dependent/Koha/Filter/EmbedItemsAvailability.t
    t/db_dependent/Serials.t
    t/db_dependent/XISBN.t
    t/db_dependent/FrameworkPlugin.t

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 2 Michal Denar 2019-04-17 20:08:41 UTC
Hi Josef,
one test fails :-(

#   at t/db_dependent/Items/GetItemsForInventory.t line 138.
# Looks like you failed 1 test of 9.
t/db_dependent/Items/GetItemsForInventory.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/9 subtests

Test Summary Report
-------------------
t/db_dependent/Items/GetItemsForInventory.t (Wstat: 256 Tests: 9 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
Files=1, Tests=9,  2 wallclock secs ( 0.01 usr  0.01 sys +  1.82 cusr  0.22 csys =  2.06 CPU)
Result: FAIL
Comment 3 Josef Moravec 2019-04-18 09:32:49 UTC
(In reply to Michal Denar from comment #2)
> Hi Josef,
> one test fails :-(
> 
> #   at t/db_dependent/Items/GetItemsForInventory.t line 138.
> # Looks like you failed 1 test of 9.
> t/db_dependent/Items/GetItemsForInventory.t .. Dubious, test returned 1
> (wstat 256, 0x100)
> Failed 1/9 subtests
> 
> Test Summary Report
> -------------------
> t/db_dependent/Items/GetItemsForInventory.t (Wstat: 256 Tests: 9 Failed: 1)
>   Failed test:  7
>   Non-zero exit status: 1
> Files=1, Tests=9,  2 wallclock secs ( 0.01 usr  0.01 sys +  1.82 cusr  0.22
> csys =  2.06 CPU)
> Result: FAIL

Sorry, I can't reproduce it ;(
Comment 4 M. Tompsett 2019-07-04 01:52:18 UTC
Created attachment 91252 [details] [review]
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls

Test plan:
Run tests, at least:
    t/db_dependent/Biblio.t
    t/db_dependent/Biblio/TransformHtmlToMarc.t
    t/db_dependent/Charset.t
    t/db_dependent/Circulation/GetTopIssues.t
    t/db_dependent/Filter_MARC_ViewPolicy.t
    t/db_dependent/ImportBatch.t
    t/db_dependent/Items.t
    t/db_dependent/Items/AutomaticItemModificationByAge.t
    t/db_dependent/Items/GetItemsForInventory.t
    t/db_dependent/Koha/Filter/EmbedItemsAvailability.t
    t/db_dependent/Serials.t
    t/db_dependent/XISBN.t
    t/db_dependent/FrameworkPlugin.t

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 5 M. Tompsett 2019-07-04 02:13:39 UTC
Rebased -- bug 22696 made changes to opac-ISBDdetail.pl not necessary.
bug 22046 made changes to C4/Matcher.pm which conflicted, but were easily resolved.
Also removed unused variable.
Comment 6 Michal Denar 2019-07-04 06:41:56 UTC
Created attachment 91283 [details] [review]
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls

Test plan:
Run tests, at least:
    t/db_dependent/Biblio.t
    t/db_dependent/Biblio/TransformHtmlToMarc.t
    t/db_dependent/Charset.t
    t/db_dependent/Circulation/GetTopIssues.t
    t/db_dependent/Filter_MARC_ViewPolicy.t
    t/db_dependent/ImportBatch.t
    t/db_dependent/Items.t
    t/db_dependent/Items/AutomaticItemModificationByAge.t
    t/db_dependent/Items/GetItemsForInventory.t
    t/db_dependent/Koha/Filter/EmbedItemsAvailability.t
    t/db_dependent/Serials.t
    t/db_dependent/XISBN.t
    t/db_dependent/FrameworkPlugin.t

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Michal Denar <black23@gmail.com>
Comment 7 Bouzid Fergani 2019-07-05 19:46:18 UTC
Created attachment 91372 [details] [review]
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls

Test plan:
Run tests, at least:
    t/db_dependent/Biblio.t
    t/db_dependent/Biblio/TransformHtmlToMarc.t
    t/db_dependent/Charset.t
    t/db_dependent/Circulation/GetTopIssues.t
    t/db_dependent/Filter_MARC_ViewPolicy.t
    t/db_dependent/ImportBatch.t
    t/db_dependent/Items.t
    t/db_dependent/Items/AutomaticItemModificationByAge.t
    t/db_dependent/Items/GetItemsForInventory.t
    t/db_dependent/Koha/Filter/EmbedItemsAvailability.t
    t/db_dependent/Serials.t
    t/db_dependent/XISBN.t
    t/db_dependent/FrameworkPlugin.t

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Michal Denar <black23@gmail.com>
Signed-off-by: Bouzid Fergani <bouzid.fergani@inlibro.com>
Comment 8 Katrin Fischer 2019-07-06 16:50:24 UTC
Created attachment 91397 [details] [review]
Bug 22721: Remove frameworkcode parameter in GetMarcFromKohaField calls

Test plan:
Run tests, at least:
    t/db_dependent/Biblio.t
    t/db_dependent/Biblio/TransformHtmlToMarc.t
    t/db_dependent/Charset.t
    t/db_dependent/Circulation/GetTopIssues.t
    t/db_dependent/Filter_MARC_ViewPolicy.t
    t/db_dependent/ImportBatch.t
    t/db_dependent/Items.t
    t/db_dependent/Items/AutomaticItemModificationByAge.t
    t/db_dependent/Items/GetItemsForInventory.t
    t/db_dependent/Koha/Filter/EmbedItemsAvailability.t
    t/db_dependent/Serials.t
    t/db_dependent/XISBN.t
    t/db_dependent/FrameworkPlugin.t

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Michal Denar <black23@gmail.com>
Signed-off-by: Bouzid Fergani <bouzid.fergani@inlibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Katrin Fischer 2019-07-06 16:51:05 UTC
Didn't spot any more occurrences. Does this warrant a check in the QA tools?
Comment 10 Martin Renvoize 2019-07-15 11:21:46 UTC
Nice work!

Pushed to master for 19.11.00
Comment 11 Fridolin SOMERS 2019-08-06 13:16:31 UTC
Enhancement not pushed to 19.05.x