Bug 22984

Summary: Holding branch disappears after saving to course and isn't restored when removing item from course
Product: Koha Reporter: Jessie Zairo <jzairo>
Component: Course reservesAssignee: Bugs List <koha-bugs>
Status: RESOLVED DUPLICATE QA Contact: Testopia <testopia>
Severity: normal    
Priority: P5 - low CC: jonathan.druart+koha, katrin.fischer
Version: 18.05   
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23083
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:

Description Jessie Zairo 2019-05-23 21:15:12 UTC
When adding a course reserve item to a record, the holdingbranch is disappearing from the item once removed from the course. 

When the item is assigned to a course, the permanent holdingbranch isn't being recorded in the course_items table. This is where the data should be stored for safe-keeping to be used when the item is removed from a course and needs to be flipped back to the original codes!
Comment 1 Katrin Fischer 2019-06-02 09:27:53 UTC
Hi Jessie, 
I just tested this on master and can't replicate the problem. Can you confirm this is still a problem in 18.05 or later?
Comment 2 Katrin Fischer 2019-07-10 06:19:55 UTC
I think this is a duplicate of bug 22142 - please undo if I was mistaken.

*** This bug has been marked as a duplicate of bug 22142 ***