Bug 2562

Summary: SYSPREFS: 'languages' and 'opaclanguages' sysprefs *dont* set default languages
Product: Koha Reporter: Chris Cormack <chris>
Component: I18N/L10NAssignee: Galen Charlton <gmcharlt>
Status: CLOSED DUPLICATE QA Contact: Bugs List <koha-bugs>
Severity: normal    
Priority: P3 CC: frederic, magnus, nengard
Version: master   
Hardware: PC   
OS: All   
See Also: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3754
Change sponsored?: --- Patch complexity: ---
Who signed the patch off: Text to go in the release notes:
Version(s) released in:

Description Chris Cormack 2010-05-21 00:52:53 UTC


---- Reported by mason@kohaaloha.com 2008-08-26 22:04:19 ----

Hi All,

from a koha3-stable install, 'languages' and 'opaclanguages' sysprefs *dont* set default languages.

they actually set the *available* languages for selection.

to fix - We need to make another pair of sysprefs

OpacLangDefault
OpacLangAvailable

LangDefault
LangAvailable

or whatever names you prefer...

is this the best way? 
Josh, this is your area, any preferences??

cheers, Mason.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:52 UTC  ---

This bug was previously known as _bug_ 2562 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2562

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was mason@kohaaloha.com.

Comment 1 Magnus Enger 2011-03-24 13:56:02 UTC
I'm seeing this too. 

I have a server where English, Swedish and Norwegian are all installed. Then I have an installation where only English and Swedish are "activated" in the opaclanguages syspref. When I browse to the OPAC of this installation with my preferred language set to nb-no (Norwegian) in Firefox I see it it Norwegian, even though that language is not activated for this OPAC. I would consider that a bug, not a feature...
Comment 2 Magnus Enger 2011-06-07 21:41:18 UTC

*** This bug has been marked as a duplicate of bug 6481 ***