Bug 27497

Summary: Display Koha version in staff interface home page
Product: Koha Reporter: Fridolin Somers <fridolin.somers>
Component: Staff ClientAssignee: Fridolin Somers <fridolin.somers>
Status: RESOLVED FIXED QA Contact: Testopia <testopia>
Severity: enhancement    
Priority: P5 - low CC: barbara.johnson, bugzilla, dcook, gmcharlt, jonathan.druart+koha, lisettepalouse+koha, lucas, madamyk, oleonard, tomascohen
Version: masterKeywords: release-notes-needed
Hardware: All   
OS: All   
See Also: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27097
Change sponsored?: --- Patch complexity: Trivial patch
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.11.00
Attachments: Bug 27497: Display Koha version in header under logo in staff interface
Bug 27497: [DO NOT PUSH] Compiled CSS
Screenshot
Bug 27497: (follow-up) Suggested new placement
Bug 27497: Display Koha version in header under logo in staff interface
Bug 27497: (follow-up) Suggested new placement
Bug 27497: (follow-up) Suggested new placement
Display version in lower right corner of home page in staff client
Bug 27497: Display Koha version in staff interface home page
Screenshot with patch
Bug 27497: Display Koha version in staff interface home page
Version displaying in center of page
Bug 27497: Display Koha version in staff interface home page
Screenshot
Bug 27497: Display Koha version in staff interface home page
Bug 27497: Display Koha version in staff interface home page
Bug 27497: Display Koha version in staff interface home page
Bug 27497: Display Koha version in staff interface home page
Screenshot of placement on the right
Bug 27497: Display Koha version in staff interface home page

Description Fridolin Somers 2021-01-20 15:53:08 UTC
Can be very useful to know on any page of staff interface Koha version.

I made a plugin :
https://github.com/biblibre/koha-plugin-intranet-version-in-header

But seems better to provide a patch.
Comment 1 Fridolin Somers 2021-01-20 16:02:23 UTC Comment hidden (obsolete)
Comment 2 Fridolin Somers 2021-01-20 16:02:46 UTC Comment hidden (obsolete)
Comment 3 Fridolin Somers 2021-01-20 16:06:17 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2021-01-20 16:53:23 UTC
(In reply to Fridolin Somers from comment #2)
> Bug 27497: [DO NOT PUSH] Compiled CSS

I don't think it's necessary to submit compiled CSS anymore, is it?
Comment 5 Barbara Johnson 2021-01-20 18:10:07 UTC
I think the lower right-hand side of the page would be a better place to display the version number. I think if my staff sees just 20.05.06 floating under the logo I will get lots of questions regarding what it is.

I also think it needs to have the word 'version' included in order to make it very explicit as to what the numbers mean, such as 'version 20.05.06'.    

Being in the lower right-hand side of the page mirrors the standard placement of the "Powered by Koha" that displays on the OPAC.
Comment 6 David Cook 2021-01-20 23:39:13 UTC
(In reply to Barbara Johnson from comment #5)
> I think the lower right-hand side of the page would be a better place to
> display the version number. I think if my staff sees just 20.05.06 floating
> under the logo I will get lots of questions regarding what it is.
> 
> I also think it needs to have the word 'version' included in order to make
> it very explicit as to what the numbers mean, such as 'version 20.05.06'.    
> 
> Being in the lower right-hand side of the page mirrors the standard
> placement of the "Powered by Koha" that displays on the OPAC.

I agree with Barbara. I don't like seeing the version floating under the logo. One of the first things I'd do on a new Koha would be to hide that. 

This patch seems useful on its own without the version number though! Good bit of refactoring.
Comment 7 Fridolin Somers 2021-01-26 07:06:27 UTC
(In reply to Barbara Johnson from comment #5)
> I think the lower right-hand side of the page would be a better place to
> display the version number. I think if my staff sees just 20.05.06 floating
> under the logo I will get lots of questions regarding what it is.
> 
> I also think it needs to have the word 'version' included in order to make
> it very explicit as to what the numbers mean, such as 'version 20.05.06'.
Ok good idea
    
> 
> Being in the lower right-hand side of the page mirrors the standard
> placement of the "Powered by Koha" that displays on the OPAC.
Ok.
But actually in staff interface, if there is no language select possibility there is no lower bar in the page.
Is it OK to always show a lower floating bar to the page ?

Your librarians are very happy to see the exact version of Koha so they can see what bug fix or feature is inside :D
Comment 8 Fridolin Somers 2021-01-26 07:18:54 UTC
And what do you think displaying the version below "About Koha" in main page ?
Since version is displayed is this page about.pl
Comment 9 Lisette Scheer 2021-01-26 16:07:47 UTC
(In reply to Fridolin Somers from comment #8)
> And what do you think displaying the version below "About Koha" in main page
> ?
> Since version is displayed is this page about.pl

+1
I really like this idea.
Comment 10 Owen Leonard 2021-01-26 17:29:51 UTC Comment hidden (obsolete)
Comment 11 David Cook 2021-01-26 23:16:47 UTC
*** Bug 27097 has been marked as a duplicate of this bug. ***
Comment 12 wainuiwitikapark 2021-01-28 22:31:59 UTC Comment hidden (obsolete)
Comment 13 wainuiwitikapark 2021-01-28 22:32:03 UTC Comment hidden (obsolete)
Comment 14 Katrin Fischer 2021-01-31 13:28:31 UTC Comment hidden (obsolete)
Comment 15 Katrin Fischer 2021-01-31 13:29:55 UTC
It feels like most/all of the changes in the first page might no longer be needed with the second patch. The changes don't hurt and are a bit of a little clean-up, so I'd be ok with them, but maybe Owen wants to weigh in?
Comment 16 Fridolin Somers 2021-02-01 09:19:27 UTC
(In reply to Fridolin Somers from comment #8)
> And what do you think displaying the version below "About Koha" in main page
> ?
> Since version is displayed is this page about.pl

Can we also add it in main page ?
"About Koha" under "Koha administration" ?
Comment 17 Barbara Johnson 2021-02-01 15:41:10 UTC
I agree with Fridolin.  My hope was that the version would display more prominently without having to click on 'About Koha' or 'More.'  I attached a screenshot that shows the version in the lower right hand corner of the main/hone page.
Comment 18 Barbara Johnson 2021-02-01 15:42:37 UTC
Created attachment 116172 [details]
Display version in lower right corner of home page in staff client
Comment 19 David Cook 2021-02-01 22:35:57 UTC
(In reply to Barbara Johnson from comment #17)
> I agree with Fridolin.  My hope was that the version would display more
> prominently without having to click on 'About Koha' or 'More.'  I attached a
> screenshot that shows the version in the lower right hand corner of the
> main/hone page.

I like the sound of this too
Comment 20 Fridolin Somers 2021-02-02 16:59:55 UTC
(In reply to Barbara Johnson from comment #18)
> Created attachment 116172 [details]
> Display version in lower right corner of home page in staff client

Showing at the bottom may not be visible on a small screen.
Or make it float ? add in into language bar ?

I propose in the header :
https://github.com/biblibre/koha-plugin-intranet-version-in-header/blob/trunk/Screenshot.png

Or maybe above the news in the main page ?
Comment 21 Owen Leonard 2021-02-02 17:22:28 UTC
And if all these choices aren't obvious enough? ;)

https://snipboard.io/1POznS.jpg
Comment 22 David Cook 2021-02-02 22:37:57 UTC
(In reply to Fridolin Somers from comment #20)
> Showing at the bottom may not be visible on a small screen.
 
I doubt we'd need to worry about a small screen for the staff interface though?

> I propose in the header :
> https://github.com/biblibre/koha-plugin-intranet-version-in-header/blob/
> trunk/Screenshot.png
 
I think it looks strange there. Like it's a navigation option when it's not. 

--

I've tried to look for examples elsewhere, but I have 0 examples where the version number is shown on the main screen of the application. So maybe we are going about this the wrong way.

It's tempting to add a News item mentioning upgrades to the staff interface, although that might interfere with how people use the News system in practice.

--

Or... we just keep it as a plugin.
Comment 23 Fridolin Somers 2021-02-03 10:06:08 UTC
I propose we vote in mailling list.
Comment 24 David Cook 2021-02-04 03:57:47 UTC
(In reply to Fridolin Somers from comment #23)
> I propose we vote in mailling list.

Sounds good to me. I don't feel passionately enough about this one to advocate any particular position.
Comment 25 Tomás Cohen Arazi 2021-02-04 18:22:07 UTC
(In reply to Barbara Johnson from comment #18)
> Created attachment 116172 [details]
> Display version in lower right corner of home page in staff client

I vote for this option :-D

I'd put 'powered by Koha 20.05.08' instead, but generally prefer this option.
Comment 26 Katrin Fischer 2021-02-06 19:08:47 UTC
I like Barbara's suggestion at the bottom of the page, like "credits".
It also doesn't work for in the top navigation, as this is misleading and we already have a lot of stuff going on there.

I'd also be happy with the initial patch here showing it in the pull down.
Comment 27 Barbara Johnson 2021-02-08 15:25:30 UTC
I prefer the lower right-hand corner option.  Displaying it like "credits" really makes sense to me.
Comment 28 Fridolin Somers 2021-02-10 08:30:46 UTC
(In reply to Barbara Johnson from comment #27)
> I prefer the lower right-hand corner option.  Displaying it like "credits"
> really makes sense to me.

OK seems the most wanted option.
And its really a small change, which will be easy to hide.

I'm on a patch.
Comment 29 Fridolin Somers 2021-02-11 10:41:33 UTC Comment hidden (obsolete)
Comment 30 Fridolin Somers 2021-02-11 10:42:27 UTC
Created attachment 116704 [details]
Screenshot with patch
Comment 31 Owen Leonard 2021-02-11 11:54:23 UTC Comment hidden (obsolete)
Comment 32 Michael Adamyk 2021-02-11 23:23:07 UTC
Created attachment 116781 [details]
Version displaying in center of page

The version is not appearing where expected for me. Instead of appearing in the lower-right corner, it's beneath the middle column (directly beneath "Authorities")
Comment 33 ByWater Sandboxes 2021-02-11 23:23:51 UTC Comment hidden (obsolete)
Comment 34 Michael Adamyk 2021-02-11 23:26:23 UTC
The version did not appear where expected in my sandbox. I'm marking it as "Failed QA" so you can take another look at it.
Comment 35 Fridolin Somers 2021-02-12 12:37:50 UTC
(In reply to Michael Adamyk from comment #34)
> The version did not appear where expected in my sandbox. I'm marking it as
> "Failed QA" so you can take another look at it.

Ah, I dont know if sandbox can update CSS files from SCSS ?
https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client

Can someone confirm ?
Comment 36 Fridolin Somers 2021-02-12 12:45:29 UTC
@Michael Adamyk

Can you run manually 'yarn build' please ?
Comment 37 Michael Adamyk 2021-03-08 22:45:31 UTC
I'm afraid I don't know enough about Koha to know how to do the SCSS or yard rebuild. Can someone else test and see if it's working for you?
Comment 38 Katrin Fischer 2021-03-21 12:48:39 UTC
(In reply to Michael Adamyk from comment #37)
> I'm afraid I don't know enough about Koha to know how to do the SCSS or yard
> rebuild. Can someone else test and see if it's working for you?

Hi Michael, if you are using the sandboxes, there is a new option to do this from there quite easily: If you look here http://sandboxes.ptfs-europe.co.uk/# you can pick "Build CSS" from the Actions pull down. That will do the trick.
Comment 39 Katrin Fischer 2021-03-21 12:56:57 UTC
Created attachment 118564 [details]
Screenshot

I am sorry, I am not sure about this one. It looks a little too 'detached' to me? Attaching a screenshot to make sure I am looking at the right thing. No languages installed.
Comment 40 Katrin Fischer 2021-03-21 12:58:18 UTC
I realize I like the screenshot 1 best still.
Comment 41 koha-US bug tracker 2021-03-21 16:49:05 UTC
I agree with Katrin about this looking detached. It’s just floating in thin air and looks really odd in that placement.  Screenshot 1 would be my preference too.
Comment 42 David Cook 2021-03-21 23:35:44 UTC
(In reply to Katrin Fischer from comment #39)
> Created attachment 118564 [details]
> Screenshot
> 
> I am sorry, I am not sure about this one. It looks a little too 'detached'
> to me? Attaching a screenshot to make sure I am looking at the right thing.
> No languages installed.

Agreed
Comment 43 Fridolin Somers 2021-03-29 12:31:49 UTC Comment hidden (obsolete)
Comment 44 Fridolin Somers 2021-03-29 12:33:41 UTC
Ahhh my mistake, my patch adds to SCSS
  float: left

We want it at right, fixed :
  float: right

I've uploaded fixed patch, so we need signoff again.
Comment 45 Owen Leonard 2021-03-30 13:45:06 UTC
Created attachment 119005 [details] [review]
Bug 27497: Display Koha version in staff interface home page

Koha current version is very useful in staff interface.
You can find it in 'About' page but home page is the first page you
see. Display it in the lower right-hand side of the page, after
'IntranetmainUserblock' content.

Note that it is not a vertical floating text, it whould conflict with
languages floating bar.

Test plan :
1) Apply patch and update staff client CSS :
https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client
2) Look at staff interface home page and look at lower right-hand side
   of the page

Signed-off-by: Michael Adamyk <madamyk@ckls.org>

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 46 Owen Leonard 2021-03-30 13:45:20 UTC Comment hidden (obsolete)
Comment 47 Katrin Fischer 2021-04-18 09:37:13 UTC
Created attachment 119821 [details] [review]
Bug 27497: Display Koha version in staff interface home page

Koha current version is very useful in staff interface.
You can find it in 'About' page but home page is the first page you
see. Display it in the lower right-hand side of the page, after
'IntranetmainUserblock' content.

Note that it is not a vertical floating text, it whould conflict with
languages floating bar.

Test plan :
1) Apply patch and update staff client CSS :
https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client
2) Look at staff interface home page and look at lower right-hand side
   of the page

Signed-off-by: Michael Adamyk <madamyk@ckls.org>

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 48 Katrin Fischer 2021-04-18 09:40:51 UTC
Created attachment 119822 [details]
Screenshot of placement on the right
Comment 49 Katrin Fischer 2021-04-18 09:43:08 UTC
Created attachment 119823 [details] [review]
Bug 27497: Display Koha version in staff interface home page

Koha current version is very useful in staff interface.
You can find it in 'About' page but home page is the first page you
see. Display it in the lower right-hand side of the page, after
'IntranetmainUserblock' content.

Note that it is not a vertical floating text, it whould conflict with
languages floating bar.

Test plan :
1) Apply patch and update staff client CSS :
https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client
2) Look at staff interface home page and look at lower right-hand side
   of the page

Signed-off-by: Michael Adamyk <madamyk@ckls.org>

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 50 Katrin Fischer 2021-04-18 09:46:31 UTC
Sorry to say, I still feel like this is not quite where it should be :( (see screenshot) But we got 2 sign-offs and I don't want to block this longer as it can be hidden as well.

I think my problem is, that I think it should "float" more at the bottom, right above or included in the language chooser if that's visible. I'd also be happy to have it included on the "About" after thinking about this more as placing it nicely has been proven so difficult.
Comment 51 David Cook 2021-04-19 00:00:29 UTC
(In reply to Katrin Fischer from comment #50)
> Sorry to say, I still feel like this is not quite where it should be :( (see
> screenshot) 

Agreed

> I think my problem is, that I think it should "float" more at the bottom,
> right above or included in the language chooser if that's visible.

Agreed, although I'd say "fixed" to the bottom. 

--

Based on the last screenshot, it does not look very good, so I'll probably just hide it on all my installs. 

I'd say just always have a bottom bar on the staff interface, and incorporate the language choose into that bottom bar. Shouldn't be that hard at a glance.
Comment 52 Jonathan Druart 2021-04-21 13:04:00 UTC
Why is it PQA if there is still discussion and the solution does not make everybody happy? :)


It is displaying: "Version 20.12.00", when it is actually "20.12.00.034". Why don't we display the exact version?
Comment 53 Katrin Fischer 2021-04-21 13:23:56 UTC
(In reply to Jonathan Druart from comment #52)
> Why is it PQA if there is still discussion and the solution does not make
> everybody happy? :)
> 
> 
> It is displaying: "Version 20.12.00", when it is actually "20.12.00.034".
> Why don't we display the exact version?

I am actually happy with that :) The "database update number" isn't appearing anywhere in documentation like release notes, I think it would only be confusing. The idea was to make them more aware of the version they are using, I think less numbers are more here.
Comment 54 David Cook 2022-07-28 00:54:48 UTC
Frido, I like what you said about adding the version as a tooltip over the Koha logo at https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27667#c13

That would be very usable but it wouldn't be ugly or disruptive to staff users.
Comment 55 David Cook 2022-07-28 00:56:02 UTC
Actually, it looks like we have it in a meta tag (at least in 21.11) so maybe it's not that necessary after all...
Comment 56 Owen Leonard 2022-08-03 18:59:43 UTC
I think the patch we have should be accepted.
Comment 57 Jonathan Druart 2022-08-05 08:40:34 UTC
Letting Tomas decide then now.
Comment 58 Tomás Cohen Arazi 2022-08-05 15:05:29 UTC
Pushed to master for 22.11.

Nice work everyone, thanks!
Comment 59 Fridolin Somers 2022-08-09 09:15:36 UTC
Cool, thank you all :D
Comment 60 Lucas Gass 2022-09-29 17:08:22 UTC
Enhancement will not be backpoted to 22.05.x series