Bug 32631

Summary: Error when previewing record during batch record modification
Product: Koha Reporter: Owen Leonard <oleonard>
Component: ToolsAssignee: Owen Leonard <oleonard>
Status: RESOLVED FIXED QA Contact: Lucas Gass <lucas>
Severity: critical    
Priority: P5 - low CC: aleisha, andrewfh, lucas
Version: master   
Hardware: All   
OS: All   
Change sponsored?: --- Patch complexity: Trivial patch
Documentation contact: Documentation submission:
Text to go in the release notes:
This patch corrects an error in the script which outputs MARC data for preview during batch record modification.
Version(s) released in:
23.05.00,22.11.03
Attachments: Bug 32631: Error when previewing record during batch record modification
Bug 32631: Error when previewing record during batch record modification
Bug 32631: Error when previewing record during batch record modification

Description Owen Leonard 2023-01-13 14:58:16 UTC
After submitting a batch of bibliographic records for modification, clicking the "Show MARC" buttons don't work. An error is in the console:

Can't call method "as_formatted" on an undefined value at /kohadevbox/koha/svc/records/preview line 74
Comment 1 Owen Leonard 2023-01-13 15:08:11 UTC
Created attachment 145278 [details] [review]
Bug 32631: Error when previewing record during batch record modification

This patch corrects an error in the script which outputs MARC data for
preview during batch record modification.

To test, apply the patch and restart services. You will need at least
one MARC modification template in your system.

- Go to Cataloging -> Batch record modification
- Submit a batch of bibliographic records
- In the table of records that follows, click any "Show MARC" button. A
  modal window should appear with a preview of the modified record.
Comment 2 ByWater Sandboxes 2023-01-13 20:51:27 UTC
Created attachment 145325 [details] [review]
Bug 32631: Error when previewing record during batch record modification

This patch corrects an error in the script which outputs MARC data for
preview during batch record modification.

To test, apply the patch and restart services. You will need at least
one MARC modification template in your system.

- Go to Cataloging -> Batch record modification
- Submit a batch of bibliographic records
- In the table of records that follows, click any "Show MARC" button. A
  modal window should appear with a preview of the modified record.

Signed-off-by: Andrew Fuerste-Henry <andrewfh@dubcolib.org>
Comment 3 Lucas Gass 2023-01-23 22:21:50 UTC
Fix is simple and makes perfect sense, QA script is happy.
Comment 4 Lucas Gass 2023-01-23 22:22:58 UTC
Created attachment 145592 [details] [review]
Bug 32631: Error when previewing record during batch record modification

This patch corrects an error in the script which outputs MARC data for
preview during batch record modification.

To test, apply the patch and restart services. You will need at least
one MARC modification template in your system.

- Go to Cataloging -> Batch record modification
- Submit a batch of bibliographic records
- In the table of records that follows, click any "Show MARC" button. A
  modal window should appear with a preview of the modified record.

Signed-off-by: Andrew Fuerste-Henry <andrewfh@dubcolib.org>

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 5 Tomás Cohen Arazi 2023-01-27 19:19:44 UTC
Pushed to master for 23.05.

Nice work everyone, thanks!
Comment 6 Matt Blenkinsop 2023-01-31 14:29:02 UTC
Nice work everyone!

Pushed to stable for 22.11.x
Comment 7 Lucas Gass 2023-02-01 18:50:54 UTC
Not needed in 22.05.x
Comment 8 Jonathan Druart 2023-03-28 09:24:10 UTC
*** Bug 33347 has been marked as a duplicate of this bug. ***