Bug 7989

Summary: RIS export file type incorrect
Product: Koha Reporter: Milton <milton.lee>
Component: OPACAssignee: Owen Leonard <oleonard>
Status: RESOLVED DUPLICATE QA Contact:
Severity: normal    
Priority: P5 - low CC: hagud, hector.hecaxmmx, jonathan.druart+koha, katrin.fischer
Version: master   
Hardware: All   
OS: All   
See Also: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12357
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16243
Change sponsored?: --- Patch complexity: ---
Documentation contact: Documentation submission:
Text to go in the release notes:
Version(s) released in:

Description Milton 2012-04-23 00:06:05 UTC
When exporting lists to a RIS file, the TY field of the RIS file is always 'book' even if the item being exported is a journal article. The result is completely incorrect/incomplete export fields when attempting to export a journal article to, for example, a citation manager.
Comment 1 Katrin Fischer 2015-01-06 20:45:22 UTC
Reading a bit into the code, it looks like more options are possible, depending on your settings in the leader. Some things like a journal it can't recognize yet, as it would need to look at other fields in the record as well:

http://git.koha-community.org/gitweb/?p=koha.git;a=blob;f=C4/Ris.pm;h=137b99dd6af23d4b05ead08b7c2d71c6d520f0c9;hb=b4e843615a76d3a9a8516f82a2ebad96aa9c4d1a#l311
Comment 2 Katrin Fischer 2015-06-06 22:40:38 UTC
Currently the code seems to only look at LDR pos 6 - that's not sufficient to recognize serials or articles. We'd need to look at some other fields here as well.

Bug 12357 might help a little.
Comment 3 H├ęctor Eduardo Castro Avalos 2016-09-28 21:21:16 UTC

*** This bug has been marked as a duplicate of bug 16245 ***