Bug 10174 - Digest is confusing
Summary: Digest is confusing
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Whiteboard:
Keywords:
: 12387 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-02 13:06 UTC by Nicole C. Engard
Modified: 2015-12-03 22:03 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 10174: Add a tooltip to explain what is a digest (3.71 KB, patch)
2015-04-15 10:24 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED OFF] Bug 10174: Add a tooltip to explain what is a digest (3.78 KB, patch)
2015-04-15 20:45 UTC, Nick Clemens
Details | Diff | Splinter Review
[PASSED QA] Bug 10174: Add a tooltip to explain what is a digest (3.84 KB, patch)
2015-04-15 20:53 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2013-05-02 13:06:20 UTC
At every training I get asked what 'Digest' means in reference to notices.  I always explain it and people still aren't sure they get it.  If you don't subscribe to a lot of mailing lists you're not really used to that language.  The concern is that patrons will also be confused by this.  The library I'm at suggested 'Group' instead of 'Digest' - can anyone else think of other language that might work? Or even a reason why we wouldn't want all enhanced messages to be digests? As it is only 2 have the option of being a 'Digest' or not - so not make them all Digests and be done with it?

Just starting a discussion here to try and make this the most user-friendly for the patrons.

Nicole
Comment 1 Zeno Tajoli 2013-05-10 07:16:42 UTC
I suggest 'Compact many emails in one'
Comment 2 Nicole C. Engard 2013-05-10 11:42:26 UTC
That's quite a mouthful - it's a thin column that I don't want to make extra wide just to fit the label.

Nicole
Comment 3 Owen Leonard 2013-05-10 12:22:17 UTC
(In reply to comment #0)
> At every training I get asked what 'Digest' means in reference to notices.

It's unfortunate, because digest is a very unambiguous term *if* you're familiar with mailing lists. If you're not, there's no analogue to compare to.
 
> Or even a reason why we wouldn't want all enhanced
> messages to be digests?

I think this might be a more fruitful discussion than what to call digests.
Comment 4 Nicole C. Engard 2013-05-10 12:38:48 UTC
(In reply to comment #3)
> (In reply to comment #0)
> > Or even a reason why we wouldn't want all enhanced
> > messages to be digests?
> 
> I think this might be a more fruitful discussion than what to call digests.

Agreed! I just figured it might be easier to get a label change in to Koha than reworking the feature ;)
Comment 5 Katrin Fischer 2013-05-11 11:47:57 UTC
Some of our libraries are using the 'single' mail option and not the digests. I am not sure killing a feature is the answer. Would something like 'summary mail' work?
Comment 6 Nicole C. Engard 2013-05-16 16:14:11 UTC
I just got a suggestion - why not have it so that when you mouse over 'digest' it explains what it is?
Comment 7 mathieu saby 2013-05-17 09:58:51 UTC
In french, we have no exact translation for digest. For us it is the same world as "summary" or "abstract".
So we translate it by "résumé" (summary), but it sounds a bit strange.

M. Saby
Comment 8 Nicole C. Engard 2013-08-08 14:05:18 UTC
A suggestion I got today is 'consolidate' or 'consolidate emails'
Comment 9 Nicole C. Engard 2013-08-08 14:05:42 UTC
better suggestion: 'consolidate messages' or 'consolidate msgs' to save space
Comment 10 Katrin Fischer 2013-08-08 14:08:22 UTC
'consolidate msgs' might save space, but really confuse translators. I would have no idea how to translate that seeing it out of context.
Comment 11 Peggy Thrasher 2013-11-15 14:39:13 UTC
I'm not sure why people want the single messages.  For predue and due notices, they are all generated at the same time in the day, so why not group them all together?  I think that digest vs. non-digest makes sense when new messages may come in at different times of the day (like hold notices for instance).
Comment 12 Owen Leonard 2014-06-09 13:17:54 UTC
*** Bug 12387 has been marked as a duplicate of this bug. ***
Comment 13 Jonathan Druart 2015-04-15 10:24:48 UTC Comment hidden (obsolete)
Comment 14 Nick Clemens 2015-04-15 20:45:23 UTC Comment hidden (obsolete)
Comment 15 Katrin Fischer 2015-04-15 20:53:33 UTC
Created attachment 37923 [details] [review]
[PASSED QA] Bug 10174: Add a tooltip to explain what is a digest

The digest term seems to be ambiguous for some people.

This patch adds a tooltip to explain what it is (feel free to provide
a better wording).

Test plan:
Go at the OPAC and click on the "Your messaging tab", you should see an
icon close to "Digest only" to explain what is a digest.
Same at the intranet on editing/showing patron info

Signed-off-by: Nick Clemens <nick@quecheelibrary.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 16 Katrin Fischer 2015-04-15 20:54:23 UTC
I am not sure about the icon, 'i' might not work in all languages. But I really like the idea and I think styling can still be improved later.
Comment 17 Tomás Cohen Arazi 2015-04-23 16:12:34 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 18 Chris Cormack 2015-05-11 22:26:36 UTC
Pushed to 3.18.x will be in 3.18.7