Bug 10317 - Parcel should display a message when called with an nonexistent invoiceid
Summary: Parcel should display a message when called with an nonexistent invoiceid
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Keywords:
: 10536 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-23 14:12 UTC by Jonathan Druart
Modified: 2014-12-07 20:03 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10317: The parcel page display whatever if the invoiceid is unknown (6.44 KB, patch)
2013-05-23 14:48 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10317: The parcel page display whatever if the invoiceid is unknown (6.49 KB, patch)
2013-05-30 07:18 UTC, Paul Poulain
Details | Diff | Splinter Review
[PASSED QA] Bug 10317: The parcel page display whatever if the invoiceid is unknown (6.77 KB, patch)
2013-06-16 17:01 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-05-23 14:12:02 UTC

    
Comment 1 Jonathan Druart 2013-05-23 14:48:21 UTC Comment hidden (obsolete)
Comment 2 Paul Poulain 2013-05-30 07:18:21 UTC
Patch tested with a sandbox, by Cedric Vita <cedric.vita@dracenie.com>
Comment 3 Paul Poulain 2013-05-30 07:18:37 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2013-06-16 17:01:43 UTC
Created attachment 19045 [details] [review]
[PASSED QA] Bug 10317: The parcel page display whatever if the invoiceid is unknown

This patch fixes some stuffs on the parcel page.
1/ Removes dead code
2/ Display an error message if invoiceid is unset or not to refer to an
invoice
3/ Fix a bug in the note ("change note" and "add note" links)

Test plan:
1/ Try to call the invoice page with an existing invoiceid and check
that order results are consistent.
2/ Try without invoiceid or a bad invoiceid and check that an error
message is displayed.
3/ Add and change notes.

Signed-off-by: Cedric Vita <cedric.vita@dracenie.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works nicely for all tests done.
- parcel.pl with invalid invoicenumber gives a nice error message
- parcel.pl with a valid invoicenumber looks normal
- changing and editing order notes works well

Passes QA script.
Comment 5 Jonathan Druart 2013-07-05 12:08:25 UTC
*** Bug 10536 has been marked as a duplicate of this bug. ***
Comment 6 Galen Charlton 2013-07-05 16:44:59 UTC
Pushed to master.  Thanks, Jonathan!
Comment 7 Tomás Cohen Arazi 2013-07-07 00:15:46 UTC
This patch has been pushed to 3.12.x, will be in 3.12.2.

Thansk Jonathan!
Comment 8 Bernardo Gonzalez Kriegel 2013-07-14 14:48:38 UTC
Pushed to 3.10.x, will be in 3.10.8