Bug 10507 - Typo when warning about creating duplicate patron attribute
Summary: Typo when warning about creating duplicate patron attribute
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low trivial (vote)
Target Milestone: ---
Assignee: Colin Campbell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-25 23:44 UTC by Chris Dixon
Modified: 2014-12-07 20:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (2.17 KB, patch)
2013-07-09 10:39 UTC, Colin Campbell
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10507 Fix namespace collision in patron entry (2.33 KB, patch)
2013-07-09 12:18 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 10507 Fix namespace collision in patron entry (2.37 KB, patch)
2013-07-12 17:07 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dixon 2013-06-25 23:44:13 UTC
The warning reads like this: "The attribute value 1 is already is use by another patron record"
Comment 1 Colin Campbell 2013-07-09 10:39:42 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2013-07-09 12:18:08 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2013-07-12 17:07:09 UTC
Created attachment 19608 [details] [review]
Bug 10507 Fix namespace collision in patron entry

If a warning about a duplicated patron attribute is returned
the value was being passed back for display in the warning
message with the same name as the variable in errors

as the message is displayed in the context of errors
the error value 1 was being displayed not the value
duplicated as intended.
Pass the value to the template with a unique name

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

I fixed another tiny typo while signing off: "is already in use" instead
of "is already is use."

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Passes koha-qa.pl, works as advertised.
Comment 4 Galen Charlton 2013-07-12 20:58:33 UTC
Pushed to master.  Thanks, Colin!
Comment 5 Tomás Cohen Arazi 2013-07-16 20:03:26 UTC
This patch has been pushed to 3.12.x, will be in 3.12.2.

Thanks Colin!
Comment 6 Bernardo Gonzalez Kriegel 2013-08-04 19:58:49 UTC
Pushed to 3.10.x, will be in 3.10.10
Comment 7 Chris Hall 2013-09-16 08:44:26 UTC
Pushed to 3.8.x, will be in 3.8.18