Bug 10600 - Duplicate authority
Summary: Duplicate authority
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 8794 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-17 12:47 UTC by Jonathan Druart
Modified: 2014-12-07 20:02 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10600: Duplicate an authority (1.35 KB, patch)
2013-07-17 12:48 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10600: Duplicate an authority (1.44 KB, patch)
2013-08-08 21:31 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[PASSED QA] Bug 10600: Duplicate an authority (1.61 KB, patch)
2013-09-07 22:17 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 10600: Change the icon for the action duplicate (1.39 KB, patch)
2013-09-09 08:29 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 10600: Change the icon for the action duplicate (1.44 KB, patch)
2013-09-10 06:41 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-07-17 12:47:34 UTC

    
Comment 1 Jonathan Druart 2013-07-17 12:48:55 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2013-08-08 21:31:04 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-09-07 22:12:08 UTC
Hi Jonathan,
I noticed that we use a different icon for duplicating patrons - maybe we could use that here too? Functionally it seems to work fine.
Comment 4 Katrin Fischer 2013-09-07 22:17:42 UTC
Created attachment 20865 [details] [review]
[PASSED QA] Bug 10600: Duplicate an authority

A simple link allows to duplicate an existing authority.

Test plan:
1/ Go to a detail authority page
2/ Click to the "Duplicate" button
3/ Edit some fields
4/ Save
5/ The new authority is created from the existing one.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
tests pass

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
All tests pass. Template change only.
Also compared the original with the duplicated authoritiy
in MARCXML - no unwanted differences found.
Comment 5 Katrin Fischer 2013-09-07 22:19:50 UTC
Hi Jonathan, could you take a look at my question in comment 3?
Comment 6 Jonathan Druart 2013-09-09 08:29:23 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2013-09-10 06:41:04 UTC
Created attachment 20932 [details] [review]
[PASSED QA] Bug 10600: Change the icon for the action duplicate

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 8 Galen Charlton 2013-09-16 19:42:51 UTC
Pushed to master.  Thanks, Jonathan!
Comment 9 Owen Leonard 2013-09-17 09:41:41 UTC
*** Bug 8794 has been marked as a duplicate of this bug. ***