Bug 10781 - Remove C4::ILSDI::Utility
Summary: Remove C4::ILSDI::Utility
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Srdjan Jankovic
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-26 00:09 UTC by Srdjan Jankovic
Modified: 2015-06-04 23:23 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
bug_10781: Removed ILSDI::Utility (6.57 KB, patch)
2013-08-26 00:23 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
bug_10781: Removed ILSDI::Utility (6.48 KB, patch)
2013-09-30 23:39 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
bug_10781: Removed ILSDI::Utility (6.53 KB, patch)
2013-10-25 13:41 UTC, Kyle M Hall
Details | Diff | Splinter Review
bug_10781: Removed ILSDI::Utility (6.63 KB, patch)
2013-11-05 14:37 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Srdjan Jankovic 2013-08-26 00:09:23 UTC
C4::ILSDI::Utility is not really required. It contains only two routines:
* BorrowerExists() which is not used
* Availability(), used only in C4::ILSDI::Services

I propose we move Availability() to C4::ILSDI::Services and remove C4::ILSDI::Utility
Comment 1 Srdjan Jankovic 2013-08-26 00:23:15 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2013-09-23 11:19:01 UTC
Applying: bug_10781: Removed ILSDI::Utility
/usr/share/koha/testclone/.git/rebase-apply/patch:43: tab in indent.
        my ($biblionumber, $status, $msg, $location) = _availability($id);
warning: 1 line adds whitespace errors.
Using index info to reconstruct a base tree...
<stdin>:43: tab in indent.
        my ($biblionumber, $status, $msg, $location) = _availability($id);
warning: 1 line applied after fixing whitespace errors.
Falling back to patching base and 3-way merge...
Removing t/ILSDI_Utility.t
CONFLICT (modify/delete): C4/ILSDI/Utility.pm deleted in bug_10781: Removed ILSDI::Utility and modified in HEAD. Version HEAD of C4/ILSDI/Utility.pm left in tree.
Auto-merging C4/ILSDI/Services.pm
CONFLICT (content): Merge conflict in C4/ILSDI/Services.pm
Failed to merge in the changes.
Comment 3 Srdjan Jankovic 2013-09-30 23:39:56 UTC Comment hidden (obsolete)
Comment 4 I'm just a bot 2013-10-01 18:44:14 UTC
Patch applied cleanly, go forth and signoff
Comment 5 Kyle M Hall 2013-10-25 13:41:30 UTC Comment hidden (obsolete)
Comment 6 Marcel de Rooy 2013-11-05 14:37:38 UTC
Created attachment 22725 [details] [review]
bug_10781: Removed ILSDI::Utility

Test:
This should be a noop. Regression testing required:
/cgi-bin/koha/ilsdi.pl functioanality, in particuler:
GetAvailability - ?service=Describe&verb=GetAvailability
AuthenticatePatron - ?service=Describe&verb=AuthenticatePatron

ILS-DI syspref must be turned on

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 7 Marcel de Rooy 2013-11-05 14:40:22 UTC
QA Comment:
Tested both functions with ilsdi.pl. Works fine. Code looks good to me. No complaints from qa tools.
Moving from enh to bugfix. No string changes. Still looks like a candidate for 3.14.

Passed QA
Comment 8 Galen Charlton 2013-12-10 01:29:31 UTC
Pushed to master.  Thanks, Srdjan!
Comment 9 Fridolin Somers 2013-12-24 09:39:03 UTC
Patch pushed to 3.14.x, will be in 3.14.2