Bug 10866 - Books entered in malayalam language cannot to search
Summary: Books entered in malayalam language cannot to search
Status: CLOSED INVALID
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: 3.12
Hardware: PC Linux
: P5 - low critical (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-10 13:35 UTC by Sameer A
Modified: 2015-07-20 22:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 10866: Hide patron's history if intranetreadinghistory is set to not allow (4.49 KB, patch)
2015-04-22 10:20 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sameer A 2013-09-10 13:35:07 UTC
Sir,
Prior to install 3.12, i was using 3.2 and i could search the terms in malayalam language. Now in 3.12 I cannot search the titles in malayalam, but it is ok in English.  is there any solution
Comment 1 Katrin Fischer 2013-12-22 06:23:49 UTC
I think you might have used NoZebra before, which is now deprecated. Take a look in setting up ICU indexing for Zebra in your installation, there is some information on the wiki about that, but it depends a bit on how you installed Koha.
Closing this here, as it's not a bug in Koha, but most likely a configuration issue. If you still have problems, the mailing list is a good place to find help.
Comment 2 Jonathan Druart 2015-04-22 10:20:35 UTC
Created attachment 38317 [details] [review]
Bug 10866: Hide patron's history if intranetreadinghistory is set to not allow

If set to "not allow", the intranetreadinghistory pref prevent staff
members to access patron's checkout history.
But:
1/ The page is still accessible if you know the url
2/ The history can be consulted on the item history page

Test plan:
0/ Don't apply this patch
1/ Set the intranetreadinghistory to allow
2/ Go on a patron's checkout history page
3/ Open a new tab and go on a item's checkout history page
4/ Set the intranetreadinghistory to not allow
5/ Refresh both pages => no change
6/ Apply this patch
7/ Refresh both page.
On the first page, you should see a warning
On the other one, you should see that the patron column is not displayed
anymore.
Comment 3 Jonathan Druart 2015-04-22 10:21:30 UTC
(In reply to Jonathan Druart from comment #2)
> Created attachment 38317 [details] [review] [review]
> Bug 10866: Hide patron's history if intranetreadinghistory is set to not
> allow

This was for bug 10886.
Comment 4 Liz Rea 2015-07-20 22:02:48 UTC
Pushed to 3.18.x will be in 3.18.09
Comment 5 Liz Rea 2015-07-20 22:03:02 UTC
oops, wrong bug.