Bug 10893 - Location facet not working in UNIMARC
Summary: Location facet not working in UNIMARC
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: mathieu saby
QA Contact: Testopia
URL:
Whiteboard:
Keywords: rel_3_16_candidate
Depends on:
Blocks:
 
Reported: 2013-09-16 09:41 UTC by mathieu saby
Modified: 2014-12-08 13:29 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this: 2013-10-25 00:00:00
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
[PATCH] Bug 10893: fix location facet in UNIMARC (1.19 KB, patch)
2013-09-16 09:46 UTC, mathieu saby
Details | Diff | Splinter Review
Bug 10893: fix location facet in UNIMARC (1.28 KB, patch)
2014-04-09 05:08 UTC, M. Tompsett
Details | Diff | Splinter Review
[SIGNED OFF] Bug 10893: fix location facet in UNIMARC (1.56 KB, patch)
2014-04-09 06:13 UTC, M. Tompsett
Details | Diff | Splinter Review
[PASSED QA] Bug 10893: fix location facet in UNIMARC (1.65 KB, patch)
2014-04-09 09:45 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description mathieu saby 2013-09-16 09:41:33 UTC
Location facet in UNIMARC is void. In the code, it is build on 995$c, while location is store in 995$e (see record.abs).

M. Saby
Comment 1 mathieu saby 2013-09-16 09:46:50 UTC Comment hidden (obsolete)
Comment 2 Pierre Angot 2013-09-19 09:22:34 UTC
I've got a problem on sandbox.

I dont see any location facets
Comment 3 mathieu saby 2013-09-19 09:25:12 UTC
Sandboxes have several branches, maybe that could explain. Or the locations are not defined in 995$e in sandboxes, I don't know.

Let someone else try to test, and thank you for trying.

Mathieu
Comment 4 Pierre Angot 2013-09-19 09:38:36 UTC
I've made some modifications and erase the second branch.

There is still nothing :/
Comment 5 Katrin Fischer 2013-09-21 12:57:50 UTC
I have had a similar problem last week when trying to demo the 'new' location facet. Maybe it's a more general problem?
Comment 6 mathieu saby 2013-09-21 14:21:10 UTC
Well, if my patch is not working, I will take an other look after Bug 10078 is pushed, as it deals with location too.

What I can say in a sure way is that 995$c is not the standard location field, and it should be replaced with 995$e.

Mathieu
Comment 7 Katrin Fischer 2013-09-21 15:33:25 UTC
Mathieu, could you test that the location facet shows up for you? My problem was it didn't show up for MARC21 - so totally unrelated to your fix that seems logical to me.
Comment 8 I'm just a bot 2013-09-24 05:38:49 UTC
Patch applied cleanly, go forth and signoff
Comment 9 I'm just a bot 2013-10-24 19:31:47 UTC
Patch applied cleanly, go forth and signoff
Comment 10 M. Tompsett 2014-04-09 05:08:33 UTC Comment hidden (obsolete)
Comment 11 M. Tompsett 2014-04-09 06:13:13 UTC Comment hidden (obsolete)
Comment 12 mathieu saby 2014-04-09 08:36:03 UTC
Thank Mark you for rebasing and signing off!
Mathieu
Comment 13 Katrin Fischer 2014-04-09 09:45:19 UTC
Created attachment 26916 [details] [review]
[PASSED QA] Bug 10893: fix location facet in UNIMARC

Location facet in UNIMARC is void. In the code, it is build
on 995$c, while location is store in 995$e (see record.abs).
This patch replace 995$c with 995$e in Koha.pm

To test :
1. Use a UNIMARC Koha instance with ONE branch, and SEVERAL
    locations
2. Make a search in opac and staff interface : no location
    facet on the left side of the screen
3. apply the patch
4. Make the same search : location facets will be displayed

NOTE: I, Mark Tompsett, rebased this. I confirmed that 995$c
      should be 995$e (wiki, Holdings_data_fields_(9xx) page)
      Also note that the code relocated based on bug 10078,
      causing the patch to not apply.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

NOTE: The location facet did not appear in master, but after
      applying the patch, it did appear.
      Because of the code being moved, it is no longer affected
      by the branch count or singleBranchMode.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Fixes wrong subfield code for UNIMARC.
Comment 14 Galen Charlton 2014-04-29 15:49:42 UTC
Pushed to master.  Thanks, Mathieu!
Comment 15 Fridolin SOMERS 2014-12-08 13:29:06 UTC
Pushed to 3.14.x, will be in 3.14.12.