Bug 10971 - Hide EAN search option for MARC21 when 'ordering from subscription'
Summary: Hide EAN search option for MARC21 when 'ordering from subscription'
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Katrin Fischer
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 12148 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-29 17:29 UTC by Katrin Fischer
Modified: 2015-12-03 22:03 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 10971: Hide EAN search for MARC21 / template corrections (3.65 KB, patch)
2015-02-21 18:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 10971: Hide EAN search for MARC21 / template corrections (3.72 KB, patch)
2015-02-24 05:33 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 10971: Hide EAN search for MARC21 / template corrections (3.78 KB, patch)
2015-02-25 11:16 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-09-29 17:29:32 UTC

    
Comment 1 Katrin Fischer 2013-09-29 17:30:51 UTC
The filters on the subscription search when you 'order from subscription' should not show EAN, as this is only functional for UNIMARC installations.

Also "branch" should be "library" and "supplier" should be labelled "vendor".
Comment 2 Katrin Fischer 2015-02-21 18:07:34 UTC
*** Bug 12148 has been marked as a duplicate of this bug. ***
Comment 3 Katrin Fischer 2015-02-21 18:26:05 UTC Comment hidden (obsolete)
Comment 4 Brendan Gallagher 2015-02-24 05:33:54 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2015-02-25 11:16:59 UTC
Created attachment 36159 [details] [review]
Bug 10971: Hide EAN search for MARC21 / template corrections

This patch hides the EAN filter on the page for ordering from
a subscription when the marcflavour is not UNIMARC as it will
only work for this flavour currently.

It also corrects
- branch to library
- supplier to vendor
- the library code in the result list to the branch name

To test:
- Make sure you have a subscription, not the vendor
- Create a new basket for the subscription vendor
- Choose 'from a subscription' to create your order line
- Look at the filters on the left side, switch
  the marcflavour system preference to see change for
  the EAN filter
- Verify changes

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 6 Tomás Cohen Arazi 2015-04-24 23:18:08 UTC
Patch pushed to master.

Thanks Katrina!
Comment 7 Chris Cormack 2015-05-17 03:49:39 UTC
Pushed to 3.18.x will be in 3.18.7