Bug 11092 - Need a processing fee and billing fee on late notices.
Summary: Need a processing fee and billing fee on late notices.
Status: RESOLVED DUPLICATE of bug 12771
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-21 13:41 UTC by Blou
Modified: 2015-02-20 16:14 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Add a processing fee and billing fee on late notices (5.05 KB, patch)
2013-10-21 13:41 UTC, Blou
Details | Diff | Splinter Review
Add a processing fee and billing fee on late notices (5.41 KB, patch)
2013-10-21 13:41 UTC, Blou
Details | Diff | Splinter Review
Add a processing fee and billing fee on late notices (3.96 KB, patch)
2013-10-21 13:42 UTC, Blou
Details | Diff | Splinter Review
Bug 11092 - Add invoice on overdue items (13.77 KB, patch)
2014-06-06 21:26 UTC, Blou
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Blou 2013-10-21 13:41:03 UTC Comment hidden (obsolete)
Comment 1 Blou 2013-10-21 13:41:39 UTC Comment hidden (obsolete)
Comment 2 Blou 2013-10-21 13:42:07 UTC Comment hidden (obsolete)
Comment 3 M. Tompsett 2013-10-22 05:20:08 UTC
Comment on attachment 22159 [details] [review]
Add a processing fee and billing fee  on late notices

I suspect this hard-coded horror was replaced by templates. I don't know how to apply this to the current 3.10 series.
Comment 4 M. Tompsett 2013-11-05 03:21:51 UTC
Blou, you may wish to rebase this, because I can't apply this to master or 3.10.12. Your patches are also not git-bz friendly. Patch 2 bombs badly when attempting to manually apply.
Comment 5 Blou 2013-11-05 13:04:13 UTC
Comment on attachment 22160 [details] [review]
Add a processing fee and billing fee  on late notices

I attached these for the benefit of kivi, but they cause too much confusion.  I'll redo them cleanly in the master.
Comment 6 Magnus Enger 2013-12-17 13:30:16 UTC
Hi Blou! Do you know when you might be able to submit this for master? I know someone who is very interested in testing it! :-)
Comment 7 Blou 2013-12-17 13:51:13 UTC
January, at the earliest.  I have a few such Koha items stacked up, I'll start working on them after the Holidays.  That's the plan, at least.
Comment 8 Magnus Enger 2013-12-17 14:03:39 UTC
(In reply to Blou from comment #7)
> January, at the earliest.  I have a few such Koha items stacked up, I'll
> start working on them after the Holidays.  That's the plan, at least.

Cool, thanks!
Comment 9 Magnus Enger 2014-05-22 14:34:42 UTC
(In reply to Blou from comment #7)
> January, at the earliest.  I have a few such Koha items stacked up, I'll
> start working on them after the Holidays.  That's the plan, at least.

I hate to nag, but is there a new timeline for this bug?
Comment 10 Viktor Sarge 2014-05-22 14:44:30 UTC
I would love to see this make it into Koha asap :) It sounds very much like the thing we need. The most important thing for me as of now is to know if it's on it's way or if it got buried under the other things that tend to pile up.
Comment 11 Blou 2014-06-06 21:26:33 UTC
Created attachment 28716 [details] [review]
Bug 11092 - Add invoice on overdue items

This is a draft for Viktor, to see where he needs the functionnality to go.
It was my first try with the letter mechanism, and I haven't managed (yet) to
get the email in HTML.  Much formatting is still needed.

See tools/letter.pl?op=add_form&branchcode=&module=circulation&code=INVOICE for new letter added by updatedatabase.pl

	modified:   ../../installer/data/mysql/updatedatabase.pl
	modified:   ../../koha-tmpl/intranet-tmpl/prog/en/modules/tools/overduerules.tt
	modified:   overdue_notices.pl
	modified:   ../../tools/overduerules.pl

http://bugs.koha-community.org/show_bug.cgi?id=10192
Comment 12 Blou 2014-06-26 20:25:40 UTC
NOTE: We'll be getting specs to upgrade the feature quite a bit.  So this will get a new patch somewhere in August.
Comment 13 Blou 2015-02-20 16:14:32 UTC
I'm not sure exactly how to close this, but this bz will never get further.
We have developped a much larger and improved solution described in
http://wiki.koha-community.org/wiki/Overdue_Notice_Enhancement#Enhancement_to_manage_more_than_3_levels_of_overdue_notice

The following bugzillas are involved for the various steps/patches:
#13624,#12768,#12769,#12770,#12771 and #12772.

That is where our energy is being put.

*** This bug has been marked as a duplicate of bug 12771 ***