Bug 11182 - Warnings in circulation
Summary: Warnings in circulation
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Srdjan Jankovic
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-01 07:10 UTC by Srdjan Jankovic
Modified: 2014-12-07 20:07 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
bug_11182: get rid of some warnings (3.12 KB, patch)
2013-11-01 07:25 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
bug_11182: get rid of some warnings (2.60 KB, patch)
2013-11-12 07:01 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
bug_11182: get rid of some warnings (3.37 KB, patch)
2013-11-12 07:15 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (3.03 KB, patch)
2014-01-10 18:26 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (1.57 KB, patch)
2014-01-10 19:57 UTC, Mark Tompsett
Details | Diff | Splinter Review
[SIGNED OFF] Bug 11182 - get rid of some warnings (4.02 KB, patch)
2014-01-10 20:37 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (3.10 KB, patch)
2014-01-11 19:47 UTC, Jesse Weaver
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (1.62 KB, patch)
2014-01-11 20:01 UTC, Jesse Weaver
Details | Diff | Splinter Review
Bug 11182 - get rid of some warnings (4.05 KB, patch)
2014-01-12 00:57 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (3.13 KB, patch)
2014-01-17 16:17 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (1.68 KB, patch)
2014-01-17 16:17 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (3.13 KB, patch)
2014-01-17 16:18 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 - Warnings in circulation (1.68 KB, patch)
2014-01-17 16:18 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 - get rid of some warnings (4.10 KB, patch)
2014-01-17 16:18 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 [1] - Warnings in circulation (3.14 KB, patch)
2014-01-17 16:19 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 [2] - Warnings in circulation (1.69 KB, patch)
2014-01-17 16:20 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 [3] - get rid of some warnings (4.11 KB, patch)
2014-01-17 16:20 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11182 [1] - Warnings in circulation (3.21 KB, patch)
2014-01-31 16:07 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 11182 [2] - Warnings in circulation (1.74 KB, patch)
2014-01-31 16:07 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 11182 [3] - get rid of some warnings (4.16 KB, patch)
2014-01-31 16:07 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 11182: (QA followup) warning if itemBarcodeFallbackSearch set (1.73 KB, patch)
2014-01-31 16:08 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Srdjan Jankovic 2013-11-01 07:10:07 UTC
Eliminate unnecessary warnings
Comment 1 Srdjan Jankovic 2013-11-01 07:25:50 UTC Comment hidden (obsolete)
Comment 2 Srdjan Jankovic 2013-11-12 07:01:28 UTC Comment hidden (obsolete)
Comment 3 Srdjan Jankovic 2013-11-12 07:15:51 UTC Comment hidden (obsolete)
Comment 4 Mark Tompsett 2014-01-10 18:25:55 UTC
Found some additional circ/circulations.pl warnings.
Comment 5 Mark Tompsett 2014-01-10 18:26:40 UTC Comment hidden (obsolete)
Comment 6 Mark Tompsett 2014-01-10 19:05:32 UTC
Sorry to make this a split effort, but since my error log entries really did overlap with this bug, I figured I'd add my patch here. :)
Comment 7 Mark Tompsett 2014-01-10 19:57:03 UTC Comment hidden (obsolete)
Comment 8 Mark Tompsett 2014-01-10 19:57:45 UTC
Comment on attachment 24171 [details] [review]
Bug 11182 - Warnings in circulation

Silly git bz obsoleted this. :)
Comment 9 Mark Tompsett 2014-01-10 20:37:16 UTC Comment hidden (obsolete)
Comment 10 Jesse Weaver 2014-01-11 19:47:35 UTC Comment hidden (obsolete)
Comment 11 Jesse Weaver 2014-01-11 20:01:06 UTC Comment hidden (obsolete)
Comment 12 Mark Tompsett 2014-01-12 00:57:31 UTC Comment hidden (obsolete)
Comment 13 Kyle M Hall 2014-01-17 16:17:24 UTC Comment hidden (obsolete)
Comment 14 Kyle M Hall 2014-01-17 16:17:29 UTC Comment hidden (obsolete)
Comment 15 Kyle M Hall 2014-01-17 16:18:02 UTC Comment hidden (obsolete)
Comment 16 Kyle M Hall 2014-01-17 16:18:12 UTC Comment hidden (obsolete)
Comment 17 Kyle M Hall 2014-01-17 16:18:20 UTC Comment hidden (obsolete)
Comment 18 Kyle M Hall 2014-01-17 16:19:51 UTC Comment hidden (obsolete)
Comment 19 Kyle M Hall 2014-01-17 16:20:05 UTC Comment hidden (obsolete)
Comment 20 Kyle M Hall 2014-01-17 16:20:14 UTC Comment hidden (obsolete)
Comment 21 Tomás Cohen Arazi 2014-01-31 16:07:17 UTC
Created attachment 24955 [details] [review]
Bug 11182 [1] - Warnings in circulation

TEST PLAN
---------
 1) Log into staff client
 2) Click 'Circulation'
 3) Click 'Check out'
 4a) Type a patron name, click 'Submit'
 4b) If necessary, select which one, and click 'Select'
 5) Check the error logs, new warnings
 6) Apply patch
 7) Click 'Circulation'
 8) Click 'Check out'
 9a) Type a patron name, click 'Submit'
 9b) If necessary, select which one, and click 'Select'
10) Check the error logs, no new warnings
11) Click the 'Restrictions' tab
12) Click 'Add manual restriction'
13) Add a dummy restriction
14) Click the 'Restrictions' tab
15) Click 'Remove'
16) Click 'OK'
17) Confirm that no additional error log entries were added
     and adding/deleting restrictions hasn't broken.

Signed-off-by: Jesse Weaver <pianohacker@gmail.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 22 Tomás Cohen Arazi 2014-01-31 16:07:36 UTC
Created attachment 24956 [details] [review]
Bug 11182 [2] - Warnings in circulation

This deals with the warning when Circulation system preference
'WaitingNotifyAtCheckin' is set to 'Notify' and an overdue item
is checked in.

TEST PLAN
---------
 0) Feel free to backup your koha-error_log file, and then toast it.
     $ echo > ~/koha-dev/var/log/koha-error_log
 1) Log into staff client
 2) Koha administration
 3) Global system preferences
 4) Circulation
 5) Make sure WaitingNotifyAtCheckin is set to Notify.
 6) Check out tab
 7) Type patron's name
 8) Select patron if required
 9) Check out an item, but set the due date to be overdue.
10) Check in the overdue item.
11) Check the error log
     $ cat ~/koha-dev/var/log/koha-error_log | grep 284
     NOTE: the returns.pl one that will be fixed by this.
12) Apply this patch
13) Repeat steps 6 through 7, there should no new line 284 entries.

Signed-off-by: Jesse Weaver <pianohacker@gmail.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 23 Tomás Cohen Arazi 2014-01-31 16:07:49 UTC
Created attachment 24957 [details] [review]
Bug 11182 [3] - get rid of some warnings

After fuller testing, there were five problems found:
circulation.pl:273
borrower_debarments.inc:65
returns.pl:269
returns.pl:284
returns.pl:540

This patch catches returns.pl:269 and returns.pl:540
Oops. Cut-and-paste error. Corrected step 5. :)

TEST PLAN
---------
 1) Log into staff client
 2) Koha administration
 3) Global system preferences
 4) Circulation
 5) Make sure FineNotifyAtCheckin is set to Notify.
 6) Check out tab
 7) Type patron's name and click 'Submit'
 8) Select patron if required
 9) Check out an item, but set the due date to be overdue.
10) Check in the overdue item.
11) Check the error log
     $ cat ~/koha-dev/var/log/koha-error_log
     NOTE: only the warnings from lines 269 and 540 in returns.pl
           are the ones to note.
12) Apply this patch
13) Repeat steps 6 through 11, there should no new
    warnings related to lines 269 or 540 from returns.pl.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 24 Tomás Cohen Arazi 2014-01-31 16:08:05 UTC
Created attachment 24958 [details] [review]
Bug 11182: (QA followup) warning if itemBarcodeFallbackSearch set

To reproduce:
- On top of the previous patches, if you enable the itemBarcodeFallbackSearch
  syspref and do a search for a term that returns at least one result, there
  will be warnings for each result without items attached.

To test:

- In the checkout form enter a term that should return results (some of them
  without items attached)
=> There are warnings on the logs regarding a split of undef variable
- Apply the patch
- Repeat the first step
=> No warings
Comment 25 Galen Charlton 2014-04-29 18:03:18 UTC
Pushed to master.  Thanks, Srdjan, Mark, and Tomás!