Bug 11397 - Displaying itemnumber list on the Acquisition detail tab is useless
Summary: Displaying itemnumber list on the Acquisition detail tab is useless
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 8230
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-16 10:56 UTC by Jonathan Druart
Modified: 2014-12-07 20:07 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11397: Remove the itemnumber list on the Acquisition detail tab (4.63 KB, patch)
2013-12-16 10:59 UTC, Jonathan Druart
Details | Diff | Splinter Review
Itemnumbers are display without the patch (25.04 KB, image/png)
2014-01-09 10:05 UTC, Jonathan Druart
Details
[SIGNED-OFF] Bug 11397: Remove the itemnumber list on the Acquisition detail tab (4.82 KB, patch)
2014-01-09 15:07 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[PASSED QA] Bug 11397: Remove the itemnumber list on the Acquisition detail tab (5.13 KB, patch)
2014-01-18 22:27 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-12-16 10:56:49 UTC
Since we have the pref AcqItemSetSubfieldsWhenReceived and filters on the holdings tab, the list of ordered items per order is unimportant and gadget.
Comment 1 Jonathan Druart 2013-12-16 10:59:40 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2014-01-08 20:35:46 UTC
Can you provide a screenshot - or instructions to the page where this is a problem so I can see what it used to look like?
Comment 3 Jonathan Druart 2014-01-09 10:05:26 UTC
Created attachment 24050 [details]
Itemnumbers are display without the patch

Hi Nicole,
Here a screenshot of a detail page (acquisition details tab). You can see that itemnumbers are displayed, without the patch. If you apply the patch, they disappear.

See comment 30 and comment 32 from bug 8230.
Comment 4 Nicole C. Engard 2014-01-09 15:07:48 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2014-01-18 22:27:53 UTC
Created attachment 24550 [details] [review]
[PASSED QA] Bug 11397: Remove the itemnumber list on the Acquisition detail tab

Test plan:
- verify this patch does not introduce regression on the enhancement
  introduced by bug 8230.
- verify the itemnumber list does not appears anymore.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
The acquisitions details tab on the holdings table in the staff
client no longer shows the links to the items. Tests pass.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.
In my tests the itemnumbers didn't show up on the acquisition
detail tab before the patch. So the patch visually only changed
the column header for me. All other acquisition related information
showed up ok.
Comment 6 Galen Charlton 2014-01-23 17:00:30 UTC
Pushed to master.  Thanks, Jonathan!