Bug 11605 - DT: default entry is 20
Summary: DT: default entry is 20
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 11555
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-24 11:18 UTC by Jonathan Druart
Modified: 2015-06-04 23:30 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Medium patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11605: default entry is 20 for all tables using datatables (16.58 KB, patch)
2014-01-24 11:19 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 11605: default entry is 20 for all tables using datatables (16.44 KB, patch)
2014-01-30 16:48 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 11605: Fix regression (1.63 KB, patch)
2014-02-03 08:43 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11605: default entry is 20 for all tables using datatables (16.71 KB, patch)
2014-02-03 08:44 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11605: Fix regression (1.63 KB, patch)
2014-02-03 08:44 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11605: default entry is 20 for all tables using datatables (16.44 KB, patch)
2014-02-07 14:23 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11605: Fix regression (1.69 KB, patch)
2014-02-07 14:23 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2014-01-24 11:18:02 UTC
The default entry is 20 and can be apply to all tables.
Bug 11555 apply the menu entries to all tables, redefinition is useless.
Comment 1 Jonathan Druart 2014-01-24 11:19:59 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2014-01-30 16:48:54 UTC Comment hidden (obsolete)
Comment 3 Marcel de Rooy 2014-01-31 09:24:27 UTC
Comment on attachment 24672 [details] [review]
Bug 11605: default entry is 20 for all tables using datatables

Temporarily unobsoleting just for a short while. No worries :)
Comment 4 Marcel de Rooy 2014-01-31 09:25:51 UTC
Comment on attachment 24672 [details] [review]
Bug 11605: default entry is 20 for all tables using datatables

No. Doesn't work either..
Comment 5 Marcel de Rooy 2014-01-31 09:26:24 UTC
Applying: Bug 11605: default entry is 20 for all tables using datatables
fatal: sha1 information is lacking or useless (koha-tmpl/intranet-tmpl/prog/en/js/datatables.js).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 11605: default entry is 20 for all tables using datatables
Comment 6 Jonathan Druart 2014-02-03 08:36:33 UTC
Hello Marcel,
This patch depends on bug 11555 and applies correctly.
Comment 7 Marcel de Rooy 2014-02-03 08:37:45 UTC
(In reply to Jonathan Druart from comment #6)
> Hello Marcel,
> This patch depends on bug 11555 and applies correctly.

OK Sorry, probably not seen :)
Comment 8 Jonathan Druart 2014-02-03 08:43:52 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2014-02-03 08:44:33 UTC Comment hidden (obsolete)
Comment 10 Jonathan Druart 2014-02-03 08:44:45 UTC Comment hidden (obsolete)
Comment 11 Kyle M Hall 2014-02-07 14:23:43 UTC
Created attachment 25133 [details] [review]
Bug 11605: default entry is 20 for all tables using datatables

The default entry is 20 and can be apply to all tables.

Bug 11555 apply the menu entries to all tables, redefining it is
uesless and can be removed.

Test plan:
Test pages impacted by this patch and verify there is no regression on
the tables.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 12 Kyle M Hall 2014-02-07 14:23:55 UTC
Created attachment 25134 [details] [review]
Bug 11605: Fix regression

Bug 11314 overrides the iDisplayLength and aLengthMenu values and should
be kept.

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 13 Galen Charlton 2014-03-10 19:08:35 UTC
Pushed to master, along with a follow-up that extends the defaults to the new staged MARC record management table.  Thanks, Jonathan!
Comment 14 Fridolin Somers 2014-06-04 08:40:00 UTC
Pushed to 3.14.x, will be in 3.14.08

This commit :
706e138 Bug 11605: (follow-up) use DT defaults for the new Ajax staged batch page
exists in master/3.16.x but is useless for 3.14.x because it does not contain Bug 10558.