Bug 11618 - jQuery timepicker is not picked up by the i18n toolchain
Summary: jQuery timepicker is not picked up by the i18n toolchain
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 12049 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-27 12:31 UTC by paxed
Modified: 2015-06-04 23:30 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Medium patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Untranslatable text in jQuery timepicker (34.28 KB, image/png)
2014-01-27 12:31 UTC, paxed
Details
Bug 11618 - jQuery timepicker is not picked up by the i18n toolchain (111.10 KB, patch)
2014-01-27 16:46 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 11618 - jQuery timepicker is not picked up by the i18n toolchain (111.11 KB, patch)
2014-02-16 08:50 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 11618 - jQuery timepicker is not picked up by the i18n toolchain (111.21 KB, patch)
2014-02-17 11:26 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description paxed 2014-01-27 12:31:40 UTC
Created attachment 24745 [details]
Untranslatable text in jQuery timepicker

The jQuery timepicker plugin has some strings that cannot be translated via Koha i18n toolchain. ("Time", "Hour", "Minute", "Now", "Done", ...)
Comment 1 Owen Leonard 2014-01-27 16:46:41 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2014-02-16 08:50:03 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2014-02-17 11:26:25 UTC
Created attachment 25345 [details] [review]
Bug 11618 - jQuery timepicker is not picked up by the i18n toolchain

We handle internationalization of the jQuery datepicker by adding
language configuration strings to calendar.inc which can be processed by
the translation script. This patch adds a similar configuration file for
the timepicker.

This patch also upgrades the timepicker plugin to the latest version,
minified, and places it outside the prog template directory for global
use. The path in templates has been updated accordingly.

CSS has been added to more completely hide the controls for seconds,
milliseconds, and microseconds.

To test, apply the patch and clear your cache so that the browser
loads the new version of the jQuery plugin. Confirm that date and time
selection still function correctly on the circulation page, the patron
detail page, and the offline circulation page (circ/offline.pl).

Test at least one datepicker instance which does not use the
timepicker.

Run translate update on a po file and confirm that the timepicker
strings are now present.

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Works as expected, no regression found.
Comment 4 Galen Charlton 2014-02-18 21:20:44 UTC
Pushed to master.  Thanks, Owen!
Comment 5 Owen Leonard 2014-04-08 17:22:13 UTC
*** Bug 12049 has been marked as a duplicate of this bug. ***
Comment 6 Fridolin Somers 2014-06-03 12:45:30 UTC
Pushed to 3.14.x, will be in 3.14.08