Bug 11796 - Results with 6 facets have missing facet
Summary: Results with 6 facets have missing facet
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-19 20:26 UTC by Kyle M Hall
Modified: 2015-06-04 23:30 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11796 - Results with 6 facets have missing facet (1.76 KB, patch)
2014-02-19 20:28 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11796 - Results with 6 facets have missing facet (1.82 KB, patch)
2014-02-20 03:12 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 11796 - Results with 6 facets have missing facet (1.96 KB, patch)
2014-02-20 10:21 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-02-19 20:26:12 UTC
If a search gives results with 6 facets, one of those facets won't be displayed. This is due to a bug in the code that only considers great than 6 facets in one area, and less than 6 in another.
Comment 1 Kyle M Hall 2014-02-19 20:28:23 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2014-02-20 03:12:57 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2014-02-20 10:21:08 UTC
Created attachment 25484 [details] [review]
Bug 11796 - Results with 6 facets have missing facet

If a search gives results with 6 facets, one of those facets won't be
displayed. This is due to a bug in the code that only considers great
than 6 facets in one area, and less than 6 in another.

Test Plan:
1) Perform a search that should give results for 6 different libraries
2) Note you only see 5 libraries in the facets with no option to expand
3) Apply this patch
4) Repeat step 1
5) Note you now have the option to expand the facets list

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
This patch should provide a regression test but I really don't know how
to write it.
Comment 4 Galen Charlton 2014-02-20 19:02:56 UTC
Pushed to master.  Thanks, Kyle!
Comment 5 Fridolin Somers 2014-05-21 08:16:15 UTC
Pushed to 3.14.x, will be in 3.14.07

(really tricky bug, but a classic boundaries problem in mathematics)
Comment 6 Kyle M Hall 2014-06-06 13:54:20 UTC
Pushed to 3.12.x will be in 3.12.13