Bug 12210 - Baker & Taylor book jackets not disabled when BakerTaylorBookstoreURL is not populated
Summary: Baker & Taylor book jackets not disabled when BakerTaylorBookstoreURL is not ...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-07 12:36 UTC by Barton Chittenden
Modified: 2016-01-19 04:36 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 12210 - Baker & Taylor book jackets not disabled when BakerTaylorBookstoreURL is not populated (3.81 KB, patch)
2015-04-03 12:16 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12210 - Baker & Taylor book jackets not disabled when BakerTaylorBookstoreURL is not populated (5.77 KB, patch)
2015-04-06 17:14 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12210 - Baker & Taylor book jackets not disabled when BakerTaylorBookstoreURL is not populated (5.83 KB, patch)
2015-04-06 17:17 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 12210 - Baker & Taylor book jackets not disabled when BakerTaylorBookstoreURL is not populated (6.01 KB, patch)
2015-04-07 20:02 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2014-05-07 12:36:48 UTC
The description of the BakerTaylorBookstoreURL syspref says 

"Baker and Taylor "My Library Bookstore" links should be accessed at https://   isbn (this should be filled in with something like ocls.mylibrarybookstore.com/MLB/actions/searchHandler.do?nextPage=bookDetails&parentNum=10923&key=). Leave it blank to disable these links."

Leaving this syspref blank does not disable the links. Instead, they are populated without the bookstore URL: the cover image for ISBN 1575725738 will cause koha to make a request to http://1575725738, which will, of course, time out.

Leaving BakerTaylorBookstoreURL blank should disable any URL that depends on this syspref, as stated in the syspref description.
Comment 1 Galen Charlton 2014-05-07 16:16:40 UTC
Is this for a case where the library has BakerTaylorEnabled set to true (because they are getting cover images) but are not using the bookstore feature?
Comment 2 Peggy Thrasher 2014-05-07 16:21:39 UTC
Yes.  It is my library.
Peggy
Comment 3 Galen Charlton 2014-05-07 16:30:01 UTC
Thanks.  Here's is a statement of the expected behavior; please let me know if it's correct:

* If BakerTaylorEnabled is off, all B&T content, including cover images and links to the bookstore should be disabled.
* If BakerTaylorEnabled is on, B&T ContentCafe links should be displayed.
* If BakerTaylorEnabled is on and BakerTaylorBookstoreURL is set to a value, B&T cover images should be displayed, with links to the bookstore.

Here's a question: is it possible to get cover images from B&T without using their bookstore service, or do they go hand-in-hand?
Comment 4 Peggy Thrasher 2014-05-29 21:15:28 UTC
Hi Galen,

This is what they said about the book jackets (we purchase them from Baker and Taylor through EBSCO).  So it sounds like we can remove the link (or make it point to the detail record - that would be my choice!)


Hello Peggy,
We have consulted with our senior colleague, and he agreed  and said your developer is more than welcome to remove the link.
Thanks again for your patience and let me know if there is anything else I can assist you with.

Please let me know if you have any questions or if I can be of further assistance. This response was sent from our case management system. When replying, please use the “Reply” button and respond directly to this email to ensure your response is received and documented in this case.

Regards,
Michael Seretse-Khama
Technical Support Representative
NoveList, a division of EBSCO
Comment 5 Martin Renvoize 2015-01-07 08:13:23 UTC
This 'might' be a good one for the Catalyst Academy.. marking as thus.
Comment 6 Justin Vos 2015-01-14 03:09:39 UTC
I don't have a username/password, but if someone is able to provide me a  BakerTaylorUsername and BakerTaylorPassword login, I would be happy to test and fix this bug.
Comment 7 Peggy Thrasher 2015-01-15 14:54:38 UTC
I have sent you credentials in an email.
Comment 8 Kyle M Hall 2015-04-03 12:16:49 UTC Comment hidden (obsolete)
Comment 9 Kyle M Hall 2015-04-06 17:14:51 UTC Comment hidden (obsolete)
Comment 10 Kyle M Hall 2015-04-06 17:17:24 UTC Comment hidden (obsolete)
Comment 11 Katrin Fischer 2015-04-07 20:02:10 UTC
Created attachment 37551 [details] [review]
[PASSED QA] Bug 12210 - Baker & Taylor book jackets not disabled when BakerTaylorBookstoreURL is not populated

The description of the BakerTaylorBookstoreURL syspref says
"Baker and Taylor "My Library Bookstore" links should be accessed at
https://   isbn (this should be filled in with something like
ocls.mylibrarybookstore.com/MLB/actions/searchHandler.do?nextPage=bookDetails&parentNum=10923&key=).
Leave it blank to disable these links."

Leaving this syspref blank does not disable the links. Instead, they are
populated without the bookstore URL: the cover image for ISBN 1575725738
will cause koha to make a request to http://1575725738, which will, of
course, time out.

Leaving BakerTaylorBookstoreURL blank should disable any URL that
depends on this syspref, as stated in the syspref description.

Test Plan:
1) Apply this patch
2) Enable Baker & Taylor cover images, but *not* BakerTaylorBookstoreURL
3) Perform an OPAC search where you have B&T cover images in the results
4) Note the image links now direct you to the record details

Signed-off-by: Sheila Kearns <sheila.kearns@state.vt.us>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Only affects Baker & Taylor related parts of the code.
Read the code carefully, but couldn't test in the OPAC.
Comment 12 Tomás Cohen Arazi 2015-04-08 13:59:34 UTC
Patch pushed to master.

Thanks Kyle!