Bug 12233 - remove prog and CCSR OPAC themes
Summary: remove prog and CCSR OPAC themes
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 10433 11346 12245 12246 12494 12512 12513 16516 21127
  Show dependency treegraph
 
Reported: 2014-05-12 14:59 UTC by Galen Charlton
Modified: 2018-07-27 12:30 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12233: Remove the prog and ccsr themes files (5.48 MB, patch)
2014-08-10 13:42 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 12233: change opacthemes syspref from {prog|ccsr} to bootstrap (1.09 KB, patch)
2014-08-10 13:43 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Galen Charlton 2014-05-12 14:59:08 UTC
Per the 3.14.0 release notes:

"The 'prog' and 'CCSR' public catalog themes are deprecated as of the
release of Koha 3.14.0.  Existing Koha sites are encouraged to switch
to the Bootstrap theme as soon as convenient.  The 'prog' and 'CCSR'
OPAC themes are slated to be completely removed in the second major
release of Koha after 3.14.0, i.e., in the release currently
contemplated for November 2014."

Presumably during upgrade, if the opactheme system preference is set to either 'prog' or 'ccsr', it should be changed to 'bootstrap'.  If it's set to anything else, it should probably not be changed, as that condition would suggest that the library has been maintaining a custom theme.
Comment 1 Tomás Cohen Arazi 2014-06-21 21:48:55 UTC

*** This bug has been marked as a duplicate of bug 11346 ***
Comment 2 Liz Rea 2014-06-22 22:40:52 UTC
I think this is actually a dependent of bug 11346, as it will be one of the tasks necessary to deprecate the theme :)

Liz
Comment 3 Tomás Cohen Arazi 2014-08-10 13:42:31 UTC
Created attachment 30654 [details] [review]
Bug 12233: Remove the prog and ccsr themes files
Comment 4 Tomás Cohen Arazi 2014-08-10 13:43:37 UTC
Created attachment 30655 [details] [review]
Bug 12233: change opacthemes syspref from {prog|ccsr} to bootstrap
Comment 5 Chris Cormack 2014-08-16 02:03:03 UTC
Pushed to MM-OPAC/theme_dep to make testing easier, once this branch is fully tested we can merge to master
Comment 6 Tomás Cohen Arazi 2014-10-30 00:32:04 UTC
Patches pushed to master.