Bug 12295 - Javascript error when merging authorities
Summary: Javascript error when merging authorities
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
: 12579 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-20 18:57 UTC by Kyle M Hall
Modified: 2019-06-27 09:24 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12295 - Javascript error when merging authorities (2.11 KB, patch)
2014-05-20 19:01 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 12295 - Javascript error when merging authorities (2.42 KB, patch)
2014-05-27 19:37 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 12295: fix Javascript error when merging authorities (2.47 KB, patch)
2014-05-27 21:03 UTC, Galen Charlton
Details | Diff | Splinter Review
Bug 12295: fix Javascript error when merging authorities (2.48 KB, patch)
2014-05-27 21:11 UTC, Galen Charlton
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-05-20 18:57:53 UTC
Attempting to merge authorities results in the following error:
Uncaught SyntaxError: Unexpected token u authorities-home.pl:284
    showMergingInProgress authorities-home.pl:284
    (anonymous function) authorities-home.pl:297
    o jquery.js:2
    p.fireWith jquery.js:2
    e.extend.ready jquery.js:2
    c.addEventListener.B
Comment 1 Kyle M Hall 2014-05-20 19:01:00 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2014-05-21 10:16:50 UTC
Upgrading importance to major considering that this breaks authorities merging.
Comment 3 Bernardo Gonzalez Kriegel 2014-05-27 19:37:44 UTC Comment hidden (obsolete)
Comment 4 Galen Charlton 2014-05-27 21:03:27 UTC Comment hidden (obsolete)
Comment 5 Galen Charlton 2014-05-27 21:11:00 UTC
Created attachment 28501 [details] [review]
Bug 12295: fix Javascript error when merging authorities

Attempting to merge authorities results in the following error:
Uncaught SyntaxError: Unexpected token u authorities-home.pl:284
    showMergingInProgress authorities-home.pl:284
    (anonymous function) authorities-home.pl:297
    o jquery.js:2
    p.fireWith jquery.js:2
    e.extend.ready jquery.js:2
    c.addEventListener.B

This was the result of the upgrade of jquery-cookie by the patch
for bug 11369; newer versions of jquery-cookie changed the return of
$.cookie('foo') from null to undefined when the cookie is not present.

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>
No test plan, no errors.

Test
1. search some authorities
2. click merge, on browser dev console pops reported error message
'Unexpected token u authorities-home.pl...'
No way to marge auths
3. with pach applied, merging works again

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Comment 6 Tomás Cohen Arazi 2014-06-05 15:18:26 UTC
Pushed to master.

Thanks Kyle!
Comment 7 Galen Charlton 2014-06-05 15:33:39 UTC
Pushed to 3.16.x for inclusion in 3.16.1.
Comment 8 Janusz Kaczmarek 2014-07-15 21:45:28 UTC
*** Bug 12579 has been marked as a duplicate of this bug. ***
Comment 9 Fridolin Somers 2014-07-22 08:04:18 UTC
Pushed to 3.14.x, will be in 3.14.09