Bug 12428 - "OPAC info" is not displayed in the OPAC
Summary: "OPAC info" is not displayed in the OPAC
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.16
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-16 12:38 UTC by Magnus Enger
Modified: 2016-06-21 21:37 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 12428 - "OPAC info" is not displayed in the OPAC (92.17 KB, patch)
2014-06-16 17:54 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 12428 - "OPAC info" is not displayed in the OPAC (92.19 KB, patch)
2014-06-19 20:09 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
[PASSED QA] Bug 12428 - "OPAC info" is not displayed in the OPAC (92.33 KB, patch)
2014-06-19 21:07 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 12428: (QA followup) regression tests. (2.46 KB, patch)
2014-06-23 19:43 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 12428 [3.16.x] "OPAC info" is not displayed in the OPAC (2.53 KB, patch)
2014-12-03 14:30 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED OFF]Bug 12428 [3.16.x] "OPAC info" is not displayed in the OPAC (2.57 KB, patch)
2014-12-26 22:14 UTC, Nick Clemens
Details | Diff | Splinter Review
[PASSED QA] Bug 12428 [3.16.x] "OPAC info" is not displayed in the OPAC (2.61 KB, patch)
2014-12-27 15:21 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2014-06-16 12:38:15 UTC
Bug 7264 made it possible to enter a piece of "OPAC info" for each library, and have it displayed as a tooltip on the library name in the items table on the detail view in the OPAC. This functionality now seems to be broken, I can't get anything to display when I hover over the library name. 

The Firebug JS console does not show any errors. Tested in Firefox 30.0 on Ubuntu 14.04.
Comment 2 Owen Leonard 2014-06-16 17:54:51 UTC Comment hidden (obsolete)
Comment 3 sandboxes@biblibre.com 2014-06-19 20:08:44 UTC
Patch tested with a sandbox, by Christopher Brannon <cbrannon@cdalibrary.org>
Comment 4 sandboxes@biblibre.com 2014-06-19 20:09:01 UTC Comment hidden (obsolete)
Comment 5 Christopher Brannon 2014-06-19 20:17:54 UTC
Everything works as outlined in the test plan.  Thank you, Owen, for a great patch.

Christopher
Comment 6 Katrin Fischer 2014-06-19 21:07:03 UTC Comment hidden (obsolete)
Comment 7 Tomás Cohen Arazi 2014-06-23 19:43:09 UTC Comment hidden (obsolete)
Comment 8 Tomás Cohen Arazi 2014-06-23 19:49:15 UTC
Patch pushed to master.

Thanks Owen!
Comment 9 Ed Veal 2014-09-24 21:05:09 UTC
Will this patch get back ported?
Comment 10 Tomás Cohen Arazi 2014-09-24 22:47:48 UTC
(In reply to Ed Veal from comment #9)
> Will this patch get back ported?

Please ping Galen on this matter.
Comment 11 Owen Leonard 2014-12-03 14:30:33 UTC Comment hidden (obsolete)
Comment 12 Koha Team AMU 2014-12-05 15:20:50 UTC
I applied and tested this patch on a sandbox.

It works like expected.

But I was not able to change status in "signed off". When I tried, I had the following message "It seems you don't have applied a patch, so you cannot sign it off. If you applied patches from the right report, check the commit message of the last patch. It should start with "Bug XXXXX", if not, please inform the author of the patch."
Comment 13 Katrin Fischer 2014-12-06 09:07:52 UTC
This patch is targetted at 3.16 specifically, so I think it might not be testable on a sandbox successfully.
Comment 14 Nick Clemens 2014-12-26 22:14:22 UTC Comment hidden (obsolete)
Comment 15 Katrin Fischer 2014-12-27 15:21:12 UTC
Created attachment 34722 [details] [review]
[PASSED QA] Bug 12428 [3.16.x] "OPAC info" is not displayed in the OPAC

This patch changes the footer include, adding an alias for the jQueryUI
tooltip function to prevent conflict with Bootstrap's function of the
same name.

To test, you must have at least two libraries configured with "OPAC
info" for display in the OPAC.

Modify the holdings of a title so that there is at least one item which
has different holding and home branches matching your library configured
above.

View the detail page for that record. Hovering your cursor over the
library name in the "Location" column should display the branch
information you configured for that library in a tooltip.

Signed-off-by: Nick Clemens <nick@quecheelibrary.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 16 Mason James 2015-01-16 18:10:40 UTC
Pushed to 3.16.x, patch will be in 3.16.7
Comment 17 Fridolin SOMERS 2015-01-23 13:33:12 UTC
Patch is in 3.16.x, I set to Pushed to stable
Comment 18 Fridolin SOMERS 2015-01-23 13:46:43 UTC
Pushed to 3.14.x will be in 3.14.13