Bug 12775 - Only suggestion manager can order from accepted suggestion
Summary: Only suggestion manager can order from accepted suggestion
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 12846 13424 (view as bug list)
Depends on:
Blocks: 17899
  Show dependency treegraph
 
Reported: 2014-08-15 16:01 UTC by Kyle M Hall
Modified: 2017-01-13 15:08 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12775: Suggestions should be ordered by anyone (3.51 KB, patch)
2014-09-18 08:28 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 12775: Suggestions should be ordered by anyone (3.67 KB, patch)
2014-09-26 09:35 UTC, Paola Rossi
Details | Diff | Splinter Review
[PASSED QA] Bug 12775: Suggestions should be ordered by anyone (3.62 KB, patch)
2014-10-03 17:38 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-08-15 16:01:55 UTC
Currently, only suggestion manager can order from accepted suggestion. The suggestions search used by newordersuggestion.pl always passes the the logged in borrowernumber as a managerid for a search limit. SearchSuggestions itself will then only return suggestions managed by the logged in user.
Comment 1 Katrin Fischer 2014-08-31 08:09:59 UTC
*** Bug 12846 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Druart 2014-09-17 11:22:23 UTC
What's the expected behavior?
Comment 3 Katrin Fischer 2014-09-17 11:28:44 UTC
I think in order to not annoy people... maybe a 2 step thing? like having the option to filter on your own easily? (and so avoiding to have to make this a pref?)

I agree that it has been irritating to people I showed Koha to - because it can be 2 different people approving and ordering in bigger libraries.
Comment 4 Jonathan Druart 2014-09-18 08:28:49 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2014-09-18 08:30:26 UTC
Not sure this is a major. It seems that the behavior exists for 5 years now.

Nicole and Kyle, could you tell me if this patch respond to your need?
Comment 6 Paola Rossi 2014-09-26 09:35:42 UTC Comment hidden (obsolete)
Comment 7 Kyle M Hall 2014-10-03 17:38:53 UTC
Created attachment 31992 [details] [review]
[PASSED QA] Bug 12775: Suggestions should be ordered by anyone

Currently only the suggestion manager can order from accepted
suggestion.

This patch set to default the ability to show all suggestions when
ordering from a suggestion.
2 links "show only mine" and "show all" permits to filter/show all
permissions.

Test plan:
Create an order from a suggestion and verify you are able to see all
suggestions by default.
Verify the "show only mine" link works as expected.

Signed-off-by: Paola Rossi <paola.rossi@cineca.it>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 8 Tomás Cohen Arazi 2014-11-21 19:14:22 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 9 Katrin Fischer 2014-12-09 19:47:07 UTC
*** Bug 13424 has been marked as a duplicate of this bug. ***