Bug 12817 - Remove internal item field paidfor from MARC structure
Summary: Remove internal item field paidfor from MARC structure
Status: RESOLVED DUPLICATE of bug 19919
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-25 10:36 UTC by Marcel de Rooy
Modified: 2019-04-25 10:52 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2014-08-25 10:36:34 UTC
This report is a followup of bug 7817 which deals with removing internal item field permanent_location from the MARC structure.

Unfortunately, there is some history in Koha on using paidfor in the MARC structure as local note etc.
Comment 1 Katrin Fischer 2017-02-19 22:28:14 UTC
The paidfor field was historically used for the internal item note (952$y in MARC21) for some time in the default frameworks. I think we cannot be sure that all libraries migrated that information into itemnotes_nonpublic by now. So we will need to be careful about removing it and possibly print a warning when there is still data in it.

I am not aware of another current use of it.
Comment 2 Katrin Fischer 2019-04-25 10:52:55 UTC
Moving this to be a duplicate of bug 19919 as it also discusses the removal.

*** This bug has been marked as a duplicate of bug 19919 ***