Bug 13024 - Nonpublic note not appearing in the staff client
Summary: Nonpublic note not appearing in the staff client
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low major (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
: 7142 (view as bug list)
Depends on: 13023 14100
Blocks: 15431
  Show dependency treegraph
 
Reported: 2014-10-02 14:56 UTC by Kyle M Hall
Modified: 2017-06-14 22:13 UTC (History)
13 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13024 - Nonpublic note not appearing in the staff client (13.47 KB, patch)
2015-04-24 14:44 UTC, Kyle M Hall
Details | Diff | Splinter Review
[Signed-off] Bug 13024 - Nonpublic note not appearing in the staff client (13.66 KB, patch)
2015-04-24 21:11 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 13024 - Nonpublic note not appearing in the staff client (13.64 KB, patch)
2015-12-01 17:50 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13024 [QA Followup] - Add nonpublic note to relatives' checkouts (1.48 KB, patch)
2015-12-01 17:51 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13024 - Nonpublic note not appearing in the staff client (13.70 KB, patch)
2015-12-02 10:50 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13024 [QA Followup] - Add nonpublic note to relatives' checkouts (1.54 KB, patch)
2015-12-02 10:51 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-10-02 14:56:48 UTC
The nonpublic note for items is not displayed in the staff client. It should be displayed in the following areas:
1) Checkouts (circulation.pl)
2) Checkins (returns.pl)
3) Record details ( moredetail.pl )
Comment 1 David Cook 2014-12-22 05:06:25 UTC
*** Bug 7142 has been marked as a duplicate of this bug. ***
Comment 2 Kyle M Hall 2015-04-24 14:44:36 UTC Comment hidden (obsolete)
Comment 3 Marc Véron 2015-04-24 21:11:40 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2015-04-29 14:40:55 UTC
QA comments:

1/ The items.itemnotes does not appear in the return table (already before this patch). I think it's because of circ/returns.pl:
577         $ri{itemnote} = $biblio->{'itemnotes'};
should be 
577         $ri{itemnote} = $item->{'itemnotes'};

2/ The non public notes does not appear in the relatives issues table.

3/ Do you know what is the span class "circ-hlt"?

Marked as Failed QA for 2, but it would be great to see 1 fixed too.
Comment 5 Katrin Fischer 2015-11-05 12:16:11 UTC
Ping Kyle!
Comment 6 Kyle M Hall 2015-12-01 17:50:51 UTC Comment hidden (obsolete)
Comment 7 Kyle M Hall 2015-12-01 17:51:01 UTC Comment hidden (obsolete)
Comment 8 Kyle M Hall 2015-12-01 17:52:59 UTC
(In reply to Jonathan Druart from comment #4)
> QA comments:
> 
> 1/ The items.itemnotes does not appear in the return table (already before
> this patch). I think it's because of circ/returns.pl:
> 577         $ri{itemnote} = $biblio->{'itemnotes'};
> should be 
> 577         $ri{itemnote} = $item->{'itemnotes'};

Can't reproduce, is it fixed in master?

> 
> 2/ The non public notes does not appear in the relatives issues table.
> 

Fixed!

> 3/ Do you know what is the span class "circ-hlt"?

It makes text bold and red. Not sure why we only do that for notes on the day its checked out but that's how it is.

> 
> Marked as Failed QA for 2, but it would be great to see 1 fixed too.
Comment 9 Jonathan Druart 2015-12-02 10:50:54 UTC
Created attachment 45313 [details] [review]
Bug 13024 - Nonpublic note not appearing in the staff client

The nonpublic note for items is not displayed in the staff client. It
should be displayed in the following areas:
1) Checkouts (circulation.pl)
2) Checkins (returns.pl)
3) Record details ( moredetail.pl )

Test Plan:
1) Ensure your non-public note field is mapped to the
   items.itemnotes_nonpublic database column
2) Edit an item, add a test nonpublic note
3) Check out the item, verify the note is visible in the checkouts table
4) Check in the item, verify the note is visible in the checkins table
5) View the item details, verify the note is visible and editable
   if your account has the rights to edit items

Followed test plan, works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 10 Jonathan Druart 2015-12-02 10:51:02 UTC
Created attachment 45314 [details] [review]
Bug 13024 [QA Followup] - Add nonpublic note to relatives' checkouts

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 11 Jonathan Druart 2015-12-02 10:51:47 UTC
(In reply to Kyle M Hall from comment #8)
> (In reply to Jonathan Druart from comment #4)
> > QA comments:
> > 
> > 1/ The items.itemnotes does not appear in the return table (already before
> > this patch). I think it's because of circ/returns.pl:
> > 577         $ri{itemnote} = $biblio->{'itemnotes'};
> > should be 
> > 577         $ri{itemnote} = $item->{'itemnotes'};
> 
> Can't reproduce, is it fixed in master?

Hum, it works actually. Sorry about that.
Not sure what I tested.
Comment 12 Kyle M Hall 2015-12-04 14:49:58 UTC
Patches pushed to master.

Thanks self! ; )
Comment 13 Julian Maurice 2015-12-07 10:24:49 UTC
Patches pushed to 3.22.x, will be in 3.22.1
Comment 14 Frédéric Demians 2015-12-07 13:13:44 UTC
This patch has been pushed to 3.20.x, will be in 3.20.7.
Comment 15 Katrin Fischer 2016-02-28 09:55:16 UTC
Hm, why not also show it on the details page directly? Just wondering, before filing another bug :)
Comment 16 Katrin Fischer 2016-03-23 22:05:57 UTC
(In reply to Katrin Fischer from comment #15)
> Hm, why not also show it on the details page directly? Just wondering,
> before filing another bug :)

Fixed by bug 16130!