Bug 13158 - Software error: Can't call method "as_string" on an undefined value at /usr/share/koha/lib/C4/Koha.pm line 1608.
Summary: Software error: Can't call method "as_string" on an undefined value at /usr/s...
Status: RESOLVED DUPLICATE of bug 13167
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.16
Hardware: HP Linux
: P5 - low critical (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-29 10:31 UTC by charis
Modified: 2014-11-02 16:43 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Software error: Can't call method "as_string" on an undefined value at /usr/share/koha/lib/C4/Koha.pm line 1608. For help, please send mail to the webmaster ([no address given]), giving this error m (247 bytes, text/plain)
2014-10-29 10:31 UTC, charis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description charis 2014-10-29 10:31:14 UTC
Created attachment 32886 [details]
Software error:  Can't call method "as_string" on an undefined value at /usr/share/koha/lib/C4/Koha.pm line 1608.  For help, please send mail to the webmaster ([no address given]), giving this error m

Hi all, 
Just recently after upgrading the Koha from 3.06 to 3.16.03 we have been facing problems when searching the OPAC Using certain keywords like research methods. But when I search other keywords apart from the mentioned keywords, there are no problems. Has anyone faced this kind of problem and found a solutions already? Any help would be appreciated. Thanks. 
the error messege says,
Software error: Can't call method "as_string" on an undefined value at /usr/share/koha/lib/C4/Koha.pm line 1608.
Comment 1 Marc Véron 2014-10-29 21:18:39 UTC
Hi charis

What happens if you search the catalog for the mentioned keywords (resarch methods) in staff client?

If you find biblios, what ISBN do they have?
Comment 2 Frédéric Demians 2014-11-02 16:43:30 UTC
It happens in search result containing records with invalid ISBN-13, ie ISBN-13 not beginning with 978.

*** This bug has been marked as a duplicate of bug 13167 ***