Bug 13298 - Holds ratios report ignores ordered items
Summary: Holds ratios report ignores ordered items
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low minor (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 7887 (view as bug list)
Depends on:
Blocks: 13299
  Show dependency treegraph
 
Reported: 2014-11-19 14:05 UTC by Kyle M Hall
Modified: 2016-03-07 13:44 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13298 - Holds ratios report ignores ordered items (4.20 KB, patch)
2014-11-19 14:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13298 - Holds ratios report ignores ordered items (4.30 KB, patch)
2014-12-08 16:20 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-11-19 14:05:20 UTC
The holds ratio report ignores ordered items. This could cause a library to inadvertently order more copies of a title than they actually need. An option should be added to count ordered items ( i.e. any negative notforloan value ).
Comment 1 Kyle M Hall 2014-11-19 14:08:07 UTC Comment hidden (obsolete)
Comment 2 HB-NEKLS 2014-11-26 15:07:55 UTC
The holds ratio report ignores ordered items. This could cause a library
to inadvertently order more copies of a title than they actually need.
An option should be added to count ordered items ( i.e. any negative
notforloan value ).

Test Plan:
1) Apply this patch
2) Create a record with two items, one regular, one ordered.
3) Place 3 holds on the item
4) Run the reserve ratios report, by default you should see this record
5) Check the new 'include ordered' checkbox, rerun the report
6) Note that record is no longer displayed

Works as expected.
Comment 3 Jonathan Druart 2014-12-08 16:20:24 UTC
Created attachment 34183 [details] [review]
Bug 13298 - Holds ratios report ignores ordered items

The holds ratio report ignores ordered items. This could cause a library
to inadvertently order more copies of a title than they actually need.
An option should be added to count ordered items ( i.e. any negative
notforloan value ).

Test Plan:
1) Apply this patch
2) Create a record with two items, one regular, one ordered.
3) Place 3 holds on the item
4) Run the reserve ratios report, by default you should see this record
5) Check the new 'include ordered' checkbox, rerun the report
6) Note that record is no longer displayed

Signed-off-by: Heather Braum <hbraum@nekls.org>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 4 Tomás Cohen Arazi 2015-02-09 18:57:50 UTC
Patch pushed to master.

Thanks Kyle!
Comment 5 Chris Cormack 2015-02-13 01:21:56 UTC
Pushed to 3.18.x will be in 3.18.4
Comment 6 Mason James 2015-02-26 04:32:36 UTC
Possible selection for 3.16.x
Comment 7 Mason James 2015-04-22 11:00:55 UTC
Pushed to 3.16.x, will be in 3.16.10
Comment 8 Kyle M Hall 2016-03-07 13:44:17 UTC
*** Bug 7887 has been marked as a duplicate of this bug. ***