Bug 13375 - Syspref search highlight styling broken in Chrome
Summary: Syspref search highlight styling broken in Chrome
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: 3.18
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-02 22:52 UTC by Tomás Cohen Arazi
Modified: 2016-06-21 21:37 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Before the patch (168.92 KB, image/png)
2014-12-02 22:57 UTC, Tomás Cohen Arazi
Details
After the patch (168.39 KB, image/png)
2014-12-02 22:57 UTC, Tomás Cohen Arazi
Details
Bug 13375: Syspref search highlight styling broken in Chrome (1.62 KB, patch)
2014-12-02 22:59 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 13375 [Alternate] Syspref search highlight styling broken in Chrome (1.76 KB, patch)
2014-12-03 13:45 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED OFF] Bug 13375: Syspref search highlight styling broken in Chrome (1.78 KB, patch)
2014-12-03 14:25 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
[PASSED QA] Bug 13375: Syspref search highlight styling broken in Chrome (1.83 KB, patch)
2014-12-05 14:58 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2014-12-02 22:52:09 UTC
To reproduce:
- Do a syspref search, for example 'facet'.
=> FAIL: Some highlighted occurences of 'facet' have styling problems, check the attached screenshots.

Note: Firefox seems to render it properly, this is just in Chrome.
Comment 1 Tomás Cohen Arazi 2014-12-02 22:57:24 UTC
Created attachment 34075 [details]
Before the patch
Comment 2 Tomás Cohen Arazi 2014-12-02 22:57:43 UTC
Created attachment 34076 [details]
After the patch
Comment 3 Tomás Cohen Arazi 2014-12-02 22:59:35 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2014-12-03 13:45:21 UTC Comment hidden (obsolete)
Comment 5 Tomás Cohen Arazi 2014-12-03 14:25:42 UTC Comment hidden (obsolete)
Comment 6 Kyle M Hall 2014-12-05 14:58:02 UTC
Created attachment 34144 [details] [review]
[PASSED QA] Bug 13375: Syspref search highlight styling broken in Chrome

This patch encloses the the syspref description/values mix in a <div>.
It doesn't introduce any regression on other browsers (like Firefox) and
has the side effect to make Chrome render the highlighted words on
syspref searches well.

This alternate patch uses a <div> instead of a <span> because it will
sometimes contain block-level elements. Follow the same plan:

To test:
- Search for 'facet' on the sysprefs
=> FAIL: verify it has styling problems in Chrome
- Apply the patch, reload
=> SUCCESS: styling is correct

Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 7 Tomás Cohen Arazi 2014-12-17 22:40:15 UTC
Patch pushed to master.

Thanks Owen!