Bug 13404 - More System information about GRS1 vs DOM settings
Summary: More System information about GRS1 vs DOM settings
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: About (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Mirko Tietgen
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
: 13396 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-07 17:03 UTC by Mirko Tietgen
Modified: 2015-06-25 08:01 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13404 - More »System information« about GRS1 vs DOM settings (2.26 MB, patch)
2014-12-07 17:08 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 13404 - More »System information« about GRS1 vs DOM settings (7.42 KB, patch)
2014-12-07 17:40 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 13404 - More »System information« about GRS1 vs DOM settings (7.47 KB, patch)
2014-12-28 05:35 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 13404 [QA Followup] (2.36 KB, patch)
2015-01-02 16:46 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13404 - More System information about GRS1 vs DOM settings (7.44 KB, patch)
2015-02-09 09:00 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 13404 [QA Followup] (2.40 KB, patch)
2015-02-09 09:00 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 13404: [QA Follow-up] Minor rewording of some warnings (4.36 KB, patch)
2015-02-09 09:01 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2014-12-07 17:03:39 UTC
System information indicates missing <zebra_bib_index_mode> and <zebra_auth_index_mode> entries in koha-conf.xml.

This patch

- adds warnings about a possible mismatch between these settings and the actual setup
- adds info about the actual setup/what values to use for <zebra_bib_index_mode> and <zebra_auth_index_mode> if they are not set.

The assumption is that a path including 'zebra-*-dom.cfg' in the respective section indicates a DOM setup.
Comment 1 Mirko Tietgen 2014-12-07 17:08:10 UTC Comment hidden (obsolete)
Comment 2 Mirko Tietgen 2014-12-07 17:11:23 UTC
Comment on attachment 34165 [details] [review]
Bug 13404 - More »System information« about GRS1 vs DOM settings

Whoops I added a gazillion translation files. Will resend later.
Comment 3 Mirko Tietgen 2014-12-07 17:40:33 UTC Comment hidden (obsolete)
Comment 4 Mirko Tietgen 2014-12-07 17:59:25 UTC
To test:

[if you followed the wiki at some point and manually changed your zebra-biblios.cfg and zebra-authorities.cfg to DOM without renaming them, the patch won't work for you.]

Simulate the various possible combinations by changing your koha-conf.xml. Make sure to leave with the correct settings in the end ;)

- If you have <zebra_bib_index_mode> and <zebra_auth_index_mode> in your file, delete/comment them and check if there is an additional info when you reload about.pl, indicating which setting seems correct. Verify that it matches your setup.

- Simulate the other setting: change the paths to the biblio and auth server config.
-- If you use DOM, change '/your/path/zebra-biblios-dom.cfg' and '/your/path/zebra-authorities-dom.cfg' in the settings to /your/path/zebra-biblios.cfg and /your/path/zebra-authorities.cfg
-- If you use GRS1, change '/your/path/zebra-biblios.cfg' and '/your/path/zebra-authorities.cfg' in the settings to /your/path/zebra-biblios-dom.cfg and /your/path/zebra-authorities-dom.cfg
- Check the about.pl page for additional info about the setting.

- Change everything back to normal and (re)add <zebra_bib_index_mode> and <zebra_auth_index_mode>. Set them to the wrong setting: if you actually use dom, set them to 'grs1' or the other way round.
- Check about.pl, you should get an extra warning.
Comment 5 Chris Cormack 2014-12-28 05:35:23 UTC Comment hidden (obsolete)
Comment 6 Kyle M Hall 2015-01-02 16:40:39 UTC
 FAIL	about.pl
   OK	  critic
   OK	  forbidden patterns
   OK	  pod
   FAIL	  valid
		!=~ should be !~
Comment 7 Kyle M Hall 2015-01-02 16:46:06 UTC Comment hidden (obsolete)
Comment 8 Tomás Cohen Arazi 2015-01-12 14:10:34 UTC
*** Bug 13396 has been marked as a duplicate of this bug. ***
Comment 9 Marcel de Rooy 2015-01-29 13:31:52 UTC
QA Comment:
Looks good to me. Only some small questions on wording:

Info message: Your configuration file indicates that dom is the correct setting for <zebra_bib_index_mode>. 
Info message: Your configuration file indicates that grs1 is the correct setting  for <zebra_bib_index_mode>.
This is kind of arbitrary: but is this conclusion worded too strong? And would you still call grs1 a correct setting?
What about: Your configuration file seems to be setup for <dom>.
And for grs1: Your configuration file still seems to be setup for <grs1>.

Warning message: The <zebra_auth_index_mode> entry is set to dom, but your system appears to be set up for grs1 indexing. It is safe to ignore this warning if biblio search is working.
I would recommend to remove the last sentence. There is something wrong here. Let them find out and correct. If we already add 'safe to ignore', does this warning still have any function?

Please provide some feedback first before I finish QA.
Comment 10 Mirko Tietgen 2015-02-08 21:49:36 UTC
(In reply to M. de Rooy from comment #9)
> QA Comment:

> What about: Your configuration file seems to be setup for <dom>.
> And for grs1: Your configuration file still seems to be setup for <grs1>.

OK.

> 
> Warning message: The <zebra_auth_index_mode> entry is set to dom, but your
> system appears to be set up for grs1 indexing. It is safe to ignore this
> warning if biblio search is working.
> I would recommend to remove the last sentence. There is something wrong
> here. Let them find out and correct. If we already add 'safe to ignore',
> does this warning still have any function?

OK.

As GRS1 seems to be kicked out pretty soon now, I agree with your changes.
Comment 11 Marcel de Rooy 2015-02-09 09:00:00 UTC
Created attachment 35743 [details] [review]
Bug 13404 - More System information about GRS1 vs DOM settings

System information indicates missing <zebra_bib_index_mode> and <zebra_auth_index_mode> entries in koha-conf.xml.

This patch

- adds warnings about a possible mismatch between these settings and the actual setup
- adds info about the actual setup/what values to use for <zebra_bib_index_mode> and <zebra_auth_index_mode> if they are not set.

The assumption is that a path including 'zebra-*-dom.cfg' in the respective section indicates a DOM setup.

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 12 Marcel de Rooy 2015-02-09 09:00:45 UTC
Created attachment 35744 [details] [review]
Bug 13404 [QA Followup]
Comment 13 Marcel de Rooy 2015-02-09 09:01:10 UTC
Created attachment 35745 [details] [review]
Bug 13404: [QA Follow-up] Minor rewording of some warnings

Changes are confirmed with author (Mirko Tietgen). See Bugzilla.

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 14 Marcel de Rooy 2015-02-09 09:02:21 UTC
Struggling again with utf8 stuff in commit message, git/git-bz.
Had to remove some special chars here and there..

Passed QA
Comment 15 Tomás Cohen Arazi 2015-02-09 16:49:55 UTC
Patches pushed to master.

Thanks Mirko!
Comment 16 Chris Cormack 2015-02-12 22:36:56 UTC
I think this is well worth having in 3.18.4 so have pushed it to 3.18.x
Comment 17 Mirko Tietgen 2015-02-27 17:50:35 UTC
(In reply to M. de Rooy from comment #9)

> I would recommend to remove the last sentence. There is something wrong
> here. Let them find out and correct. If we already add 'safe to ignore',
> does this warning still have any function?
> 
> Please provide some feedback first before I finish QA.

Now I remember why I added that sentence… if you have an older package installation and manually switched to DOM, the check will tell you that there is a problem when it isn't. It looks for zebra-biblios-dom.cfg and gives a warning if that file is not present. But if you followed the wiki to switch to DOM indexing manually, your file will be called zebra-biblios.cfg and you will get a warning when there is no problem.