Bug 13599 - Add patron cardnumber to self registration confirmation
Summary: Add patron cardnumber to self registration confirmation
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords: rel_3_16_candidate
: 12381 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-20 12:17 UTC by Kyle M Hall
Modified: 2016-06-21 21:38 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13599 - Add patron cardnumber to self registration confirmation (1.85 KB, patch)
2015-01-20 12:19 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13599 - Add patron cardnumber to self registration confirmation (2.71 KB, patch)
2015-01-20 12:25 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13599 - Add patron cardnumber to self registration confirmation (2.85 KB, patch)
2015-01-20 12:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 13599 - Add patron cardnumber to self registration confirmation (2.96 KB, patch)
2015-01-20 19:34 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 13599 - Add patron cardnumber to self registration confirmation (2.97 KB, patch)
2015-01-27 21:11 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2015-01-20 12:17:54 UTC
Some libraries wish to display the patron's cardnumber on the confirmation screen for patron self registration, rather than make the patron locate it his or her cardnumber by logging in and browsing to the personal details page. We should also add ids to these fields for easy css styling/hiding.
Comment 1 Kyle M Hall 2015-01-20 12:19:42 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2015-01-20 12:25:49 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2015-01-20 12:39:17 UTC
*** Bug 12381 has been marked as a duplicate of this bug. ***
Comment 4 Kyle M Hall 2015-01-20 12:42:42 UTC Comment hidden (obsolete)
Comment 5 Owen Leonard 2015-01-20 19:34:58 UTC Comment hidden (obsolete)
Comment 6 Owen Leonard 2015-01-20 19:36:12 UTC
I consider this a bug-fix rather than an enhancement because of the complexity of explaining to users who register online how to find their library card number.
Comment 7 Katrin Fischer 2015-01-27 21:11:14 UTC
Created attachment 35562 [details] [review]
[PASSED QA] Bug 13599 - Add patron cardnumber to self registration confirmation

Some libraries wish to display the patron's cardnumber on the
confirmation screen for patron self registration, rather than make the
patron locate it his or her cardnumber by logging in and browsing to the
personal details page. We should also add ids to these fields for easy
css styling/hiding.

Test Plan:
1) Apply this patch
2) Ensure that autoMemberNum is enabled
3) Self-register a new patron
4) Note confirmation screen now displays the patron cardnumber

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Tomás Cohen Arazi 2015-02-04 18:55:18 UTC
Patch pushed to master.

Thanks Kyle!
Comment 9 Chris Cormack 2015-02-09 20:38:57 UTC
Pushed to 3.18.x will be in 3.18.4
Comment 10 Mason James 2015-02-26 02:44:30 UTC
(In reply to Chris Cormack from comment #9)
> Pushed to 3.18.x will be in 3.18.4

possible selection for 3.16.9