Bug 13667 - Provide script to regularly clean deletedborrowers table
Summary: Provide script to regularly clean deletedborrowers table
Status: RESOLVED DUPLICATE of bug 19008
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 18081
  Show dependency treegraph
 
Reported: 2015-02-04 17:10 UTC by Katrin Fischer
Modified: 2020-02-14 10:51 UTC (History)
6 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2015-02-04 17:10:22 UTC
Currently when a patron record is deleted in Koha the information in the table borrowers is moved to the table deletedborrowers. 

But Koha currently provides no way to clean up the table deletedborrowers regularly. The data is kept forever or has to be deleted via SQL.

We should provide a script that checks for a timestamp (see bug 8926) and deletes data older than x days. It might also be desirable to offer an option to never save data into the deletedborrowers table.
Comment 1 Katrin Fischer 2018-01-12 11:52:28 UTC
This is quite a big privacy issue. If a patron asks for his data to be deleted, it should be deleted. Keeping it might even be against law in some contexts.
Comment 2 Fridolin SOMERS 2018-04-16 10:40:49 UTC
Bug 19008 adds an option on cron job cleanup_database.pl
Comment 3 Jonathan Druart 2020-02-14 10:51:38 UTC
Done on bug 19008.

*** This bug has been marked as a duplicate of bug 19008 ***