Bug 13687 - ILS-DI services HoldItem and HoldTitle don't consider hold policy by item type
Summary: ILS-DI services HoldItem and HoldTitle don't consider hold policy by item type
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Web services (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Julian Maurice
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 10314 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-10 13:03 UTC by Julian Maurice
Modified: 2016-06-21 21:40 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13687: Move hold policy check into CanItemBeReserved (6.65 KB, patch)
2015-02-10 13:04 UTC, Julian Maurice
Details | Diff | Splinter Review
Bug 13687: Move hold policy check into CanItemBeReserved (6.70 KB, patch)
2015-02-19 09:07 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 13687: Move hold policy check into CanItemBeReserved (6.86 KB, patch)
2015-03-02 15:58 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 13687: Move hold policy check into CanItemBeReserved (6.64 KB, patch)
2015-04-23 10:17 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Maurice 2015-02-10 13:03:25 UTC
ILS-DI services HoldItem and HoldTitle don't consider hold policy by item type
Comment 1 Julian Maurice 2015-02-10 13:04:39 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2015-02-19 09:07:00 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2015-03-02 15:58:13 UTC Comment hidden (obsolete)
Comment 4 Tomás Cohen Arazi 2015-03-25 15:38:34 UTC
The patch doesn't apply. Please consider taking a look at bug 5786 on rebasing.
Comment 5 Julian Maurice 2015-04-23 10:17:14 UTC
Created attachment 38398 [details] [review]
[PASSED QA] Bug 13687: Move hold policy check into CanItemBeReserved

Rebased on master
Comment 6 Tomás Cohen Arazi 2015-05-19 15:08:00 UTC
Patch pushed to master.

Thanks Julian!
Comment 7 Kyle M Hall 2015-10-15 17:32:01 UTC
*** Bug 10314 has been marked as a duplicate of this bug. ***