Bug 13696 - Add support for Font Awesome icons in Koha
Summary: Add support for Font Awesome icons in Koha
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 14610 14915
  Show dependency treegraph
 
Reported: 2015-02-11 12:27 UTC by Kyle M Hall
Modified: 2016-06-21 21:40 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13696 - Add support for Font Awesome icons in Koha (1.81 MB, patch)
2015-02-11 12:29 UTC, Kyle M Hall
Details | Diff | Splinter Review
Screenshot showing before and after (11.00 KB, image/png)
2015-02-12 17:45 UTC, Owen Leonard
Details
Bug 13636 SAMPLE: Add support for Font Awesome icons in Koha (4.37 KB, patch)
2015-03-03 23:18 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 13636 SAMPLE: Add support for Font Awesome icons in Koha (4.96 KB, patch)
2015-03-03 23:22 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 13696 - Add support for Font Awesome icons in Koha (1.81 MB, patch)
2015-03-03 23:28 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 13696: Add new pref IconTheme (3.00 KB, patch)
2015-09-28 12:27 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13696: Pass the classes to use for icons to the templates (118.01 KB, patch)
2015-09-28 12:27 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13696 [QA Followup] - Add Font Awesome license to the about page (1.20 KB, patch)
2015-09-28 15:42 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13696 - Add support for Font Awesome icons in Koha (1.96 MB, patch)
2015-09-28 16:28 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13696 [QA Followup] - Add Font Awesome license to the about page (1.25 KB, patch)
2015-09-28 16:29 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13696 [QA Followup] - Update FA to 4.4.0 (755.44 KB, patch)
2015-10-26 16:48 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 13696 - Add support for Font Awesome icons in Koha (1.81 MB, patch)
2015-10-26 22:28 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 13696 [QA Followup] - Add Font Awesome license to the about page (1.32 KB, patch)
2015-10-26 22:28 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 13696 [QA Followup] - Update FA to 4.4.0 (755.31 KB, patch)
2015-10-26 22:28 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2015-02-11 12:27:15 UTC
Font Awesome is similar to Glyphicons included in Twitter Bootstrap, except better in every way and more Free.
Comment 1 Kyle M Hall 2015-02-11 12:29:56 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2015-02-12 17:45:13 UTC
Created attachment 35881 [details]
Screenshot showing before and after

Looks like it's not quite a drop-in replacement. I'd like to see more testing done to see why things look off-kilter.
Comment 3 Nicole C. Engard 2015-03-03 11:27:16 UTC
Owen,

Are you doing the testing? I'm not sure what I'm seeing on this that's off kilter except that the bottom buttons are smaller.

Nicole
Comment 4 Marc Véron 2015-03-03 13:52:38 UTC
Nice Icons.

Is it possible to get kind of testig patch for a template just to see how it works, e.g. to reproduce Owens's screenshot?
Comment 5 Mirko Tietgen 2015-03-03 23:18:21 UTC Comment hidden (obsolete)
Comment 6 Mirko Tietgen 2015-03-03 23:22:49 UTC Comment hidden (obsolete)
Comment 7 Mirko Tietgen 2015-03-03 23:28:19 UTC Comment hidden (obsolete)
Comment 8 Mirko Tietgen 2015-03-03 23:33:52 UTC
Patch works as promised. I came across these icons some time ago and wondered if we could use them in Koha, nice enhancement!

This is not supposed to invalidate Owen's concerns, just confirming that using the icons on a page works for me.
Comment 9 Katrin Fischer 2015-03-24 22:40:29 UTC
I am hesitating about adding those without an idea on how we plan to make use of them. Why are they more free?
Comment 10 Marc Véron 2015-03-25 06:01:19 UTC
License of Glyphicons:
http://glyphicons.com/license/

License of Font-Awesome:
http://fortawesome.github.io/Font-Awesome/license/
Comment 11 Jonathan Druart 2015-04-21 09:53:20 UTC
Kyle, what's the plan here?
How will we use these fonts?

(In reply to Katrin Fischer from comment #9)
> Why are they more free?
Comment 12 Jonathan Druart 2015-06-23 09:08:49 UTC
(In reply to Jonathan Druart from comment #11)
> Kyle, what's the plan here?
> How will we use these fonts?

ping?
Comment 13 Kyle M Hall 2015-09-23 16:34:40 UTC
The idea is just to give us more options for icons. We don't need to replace the glyphicons wholesale once this is in Koha, but we could certainly migrate away from them over time!
Comment 14 Jonathan Druart 2015-09-28 12:27:18 UTC Comment hidden (obsolete)
Comment 15 Jonathan Druart 2015-09-28 12:27:23 UTC Comment hidden (obsolete)
Comment 16 Jonathan Druart 2015-09-28 12:28:59 UTC
Trying to unblock this bug report:
I have submitted 2 new patches, they insert a new pref 'IconTheme' which can be changed from Glyphicons to Font-Awasome.
All the icons used should be impacted by this change.

Was it the idea behind this?
Comment 17 Kyle M Hall 2015-09-28 13:31:47 UTC
(In reply to Jonathan Druart from comment #16)
> Trying to unblock this bug report:
> I have submitted 2 new patches, they insert a new pref 'IconTheme' which can
> be changed from Glyphicons to Font-Awasome.
> All the icons used should be impacted by this change.
> 
> Was it the idea behind this?

That is not necessary! Glyphicons and Font-Awesome can be used side-by-side within Koha. There is no need to make this an either-or proposition!

The primary reason to add support for Font-Awesome is that it is far more powerful than Glyphicons, and is also FOSS, unlike Glyphicons. If we add support for Font Awesome to Koha, then we can, over time, replace our current usage of Glyphicons with Font Awesome until we are no longer using Glyphicons at all.
Comment 18 Jonathan Druart 2015-09-28 14:03:53 UTC
So why don't we replace them?
I don't see the point to integrate them into Koha if we don't use it.
Comment 19 Kyle M Hall 2015-09-28 15:03:42 UTC
I agree we should replace them! (In reply to Jonathan Druart from comment #18)
> So why don't we replace them?
> I don't see the point to integrate them into Koha if we don't use it.

Ok! Let's do it! Bug 14915 switches the staff side to Font Awesome icons. I will file another patch for the opac side!
Comment 20 Kyle M Hall 2015-09-28 15:22:25 UTC
I think this can go back to signed off now!
Comment 21 Kyle M Hall 2015-09-28 15:42:29 UTC Comment hidden (obsolete)
Comment 22 Jonathan Druart 2015-09-28 16:28:56 UTC Comment hidden (obsolete)
Comment 23 Jonathan Druart 2015-09-28 16:29:15 UTC Comment hidden (obsolete)
Comment 24 Jonathan Druart 2015-09-28 16:30:08 UTC
IMO this should be pushed with bug 14915, or we should comment the change in
  koha-tmpl/intranet-tmpl/prog/en/includes/doc-head-close.inc
and
  koha-tmpl/opac-tmpl/bootstrap/en/includes/doc-head-close.inc

for the next release.
Comment 25 Kyle M Hall 2015-10-26 16:48:13 UTC Comment hidden (obsolete)
Comment 26 Katrin Fischer 2015-10-26 22:28:10 UTC
Created attachment 44037 [details] [review]
[PASSED QA] Bug 13696 - Add support for Font Awesome icons in Koha

Font Awesome is similar to Glyphicons included in Twitter Bootstrap,
except better in every way and more Free.

Test Plan:
1) Apply this patch
2) Edit the template for a page, and add a Font Awesome tag to it,
   examples can be found here:
   http://fortawesome.github.io/Font-Awesome/examples/
3) Reload the page and verify the icon displays.

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 27 Katrin Fischer 2015-10-26 22:28:13 UTC
Created attachment 44038 [details] [review]
[PASSED QA] Bug 13696 [QA Followup] - Add Font Awesome license to the about page

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 28 Katrin Fischer 2015-10-26 22:28:25 UTC
Created attachment 44039 [details] [review]
[PASSED QA] Bug 13696 [QA Followup] - Update FA to 4.4.0

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 29 Tomás Cohen Arazi 2015-10-27 13:44:09 UTC
Patches pushed to master.

Good job Kyle!