Bug 13838 - Redirect to 'expired holds' tab after cancelling a hold
Summary: Redirect to 'expired holds' tab after cancelling a hold
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
: 14028 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-16 10:47 UTC by Katrin Fischer
Modified: 2017-06-14 22:10 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13838 - Redirect to 'expired holds' tab after cancelling a hold (1.23 KB, patch)
2015-04-20 19:36 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13838 - Redirect to 'expired holds' tab after cancelling a hold (3.72 KB, patch)
2015-12-09 15:01 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13838 - Redirect to 'expired holds' tab after cancelling a hold (3.75 KB, patch)
2015-12-09 19:29 UTC, Tom Misilo
Details | Diff | Splinter Review
Bug 13838 - Redirect to 'expired holds' tab after cancelling a hold (3.83 KB, patch)
2015-12-11 10:30 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2015-03-16 10:47:12 UTC
When working with the 'holds awaiting pickup' report, after cancelling a hold that has not been picked up, you are redirected to the first tab. It would be nice if the redirect led you to the second tab to save a click when working on cancelling the holds.

To test:
- Go to the holds awaiting pickup report from the circulation start page
- you will need some holds that appear on the 'hold(s) over' tab
- cancel a hold from this tab
- verify you are redirected to the report page with the first tab 'Hold(s) waiting' selected
Comment 1 Katrin Fischer 2015-04-20 19:31:46 UTC
*** Bug 14028 has been marked as a duplicate of this bug. ***
Comment 2 Kyle M Hall 2015-04-20 19:36:14 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-04-28 15:42:27 UTC
The test plan works, but I am redirected to the Hold(s) over tab even if I deleted a waiting hold (first tab).
Comment 4 Kyle M Hall 2015-12-09 15:01:55 UTC Comment hidden (obsolete)
Comment 5 Tom Misilo 2015-12-09 19:29:07 UTC Comment hidden (obsolete)
Comment 6 Tom Misilo 2015-12-09 19:32:08 UTC
Jonathan,

I tested your case as well, and it does not appear to do that with the latest patch.
Comment 7 Jonathan Druart 2015-12-11 10:30:51 UTC
Created attachment 45596 [details] [review]
Bug 13838 - Redirect to 'expired holds' tab after cancelling a hold

When canceling a hold from the holds over tab, you are redirected back to the holds waiting tab. Instead, we should the librarian should continue to see the list of holds past the waiting length.

Test Plan:
1) Apply this patch
2) Cancel a hold from the "Holds over" tab on circ/waitingreserves.pl
3) Note you are redirected back to the holds over tab

Signed-off-by: Tom Misilo <misilot@fit.edu>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Kyle M Hall 2015-12-11 16:44:30 UTC
Pushed to master!
Comment 9 Julian Maurice 2015-12-14 07:40:43 UTC
Patch pushed to 3.22.x, will be in 3.22.1
Comment 10 Frédéric Demians 2015-12-14 17:59:10 UTC
This patch has been pushed to 3.20.x, will be in 3.20.7.