Bug 13877 - seasonal predictions showing wrong in test
Summary: seasonal predictions showing wrong in test
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Alex Arnaud
QA Contact: Testopia
URL:
Keywords:
: 16290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-19 18:31 UTC by Nicole C. Engard
Modified: 2017-12-07 22:16 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
test wrong (269.68 KB, image/jpeg)
2015-03-19 18:31 UTC, Nicole C. Engard
Details
received shows right (286.54 KB, image/jpeg)
2015-03-19 18:32 UTC, Nicole C. Engard
Details
seasonal pattern not correctly predicted (99.96 KB, image/png)
2015-05-15 22:18 UTC, Katrin Fischer
Details
season in english (51.63 KB, image/png)
2015-12-09 15:41 UTC, Marjorie Barry-Vila
Details
Bug 13877 - Make serialseq season name translatable regardless its position in a string (3.65 KB, patch)
2016-03-15 15:37 UTC, Alex Arnaud
Details | Diff | Splinter Review
Bug 13877 - Make serialseq season name translatable regardless its position in a string (3.71 KB, patch)
2016-04-19 02:31 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 13877 - Fix QA issues (1.64 KB, patch)
2016-04-22 09:06 UTC, Alex Arnaud
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 13877 - Fix QA issues (1.73 KB, patch)
2016-04-27 18:22 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
[PASSED QA] Bug 13877 - Make serialseq season name translatable regardless its position in a string (3.77 KB, patch)
2016-04-28 10:46 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 13877 - Fix QA issues (1.79 KB, patch)
2016-04-28 10:46 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2015-03-19 18:31:45 UTC
Created attachment 37019 [details]
test wrong

When you test a seasonal serial prediction it shows wrong, but when you receive it it's all right.
Comment 1 Nicole C. Engard 2015-03-19 18:32:04 UTC
Created attachment 37020 [details]
received shows right
Comment 2 Katrin Fischer 2015-05-15 22:18:27 UTC
Created attachment 39228 [details]
seasonal pattern not correctly predicted

Seeing the same behaviour as Nicole - also: Locale is set to German, but seasons appear in English. Could it be the problem appears when seasonal is not first?
Comment 3 Marjorie Barry-Vila 2015-12-09 15:41:07 UTC
Created attachment 45537 [details]
season in english

Hi,
I have the same problem even if Season is on X and locale is set on French, language of prediction is always english.

When I received an issue, language is always in English.

Marjorie
Comment 4 Alex Arnaud 2016-03-15 15:37:04 UTC Comment hidden (obsolete)
Comment 5 Alex Arnaud 2016-03-15 15:41:35 UTC
Nicole, Katrin, Marjorie,

Here is a fix. In my case, the problem was present in prediction and serials-collection page.
Comment 6 Chris Cormack 2016-04-19 02:31:44 UTC Comment hidden (obsolete)
Comment 7 Kyle M Hall 2016-04-21 14:33:44 UTC
FAIL	  valid_template
		parse error - /home/vagrant/kohaclone/koha-tmpl/intranet-tmpl/prog/en/modules/serials/serials-collection.tt line 329: unexpected end of input
Comment 8 Alex Arnaud 2016-04-22 09:06:34 UTC Comment hidden (obsolete)
Comment 9 Bernardo Gonzalez Kriegel 2016-04-27 18:22:58 UTC Comment hidden (obsolete)
Comment 10 Katrin Fischer 2016-04-28 10:46:28 UTC
Created attachment 50895 [details] [review]
[PASSED QA] Bug 13877 - Make serialseq season name translatable regardless its position in a string

Signed-off-by: Chris Cormack <chrisc@catalyst.net.z>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 11 Katrin Fischer 2016-04-28 10:46:59 UTC
Created attachment 50896 [details] [review]
[PASSED QA] Bug 13877 - Fix QA issues

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>
No koha-qa errors

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 12 Brendan Gallagher 2016-04-29 02:45:39 UTC
Pushed to Master - should be in the May 2016 - Release.   Thanks!
Comment 13 Julian Maurice 2016-05-09 09:54:12 UTC
Patches pushed to 3.22.x, will be in 3.22.7
Comment 14 Jonathan Druart 2016-06-18 12:44:17 UTC
*** Bug 16290 has been marked as a duplicate of this bug. ***
Comment 15 Chris Cormack 2016-06-19 21:52:11 UTC
Pushed to 3.20.x will be in 3.20.11