Bug 14032 - Delete item "confirm" only works in Firefox
Summary: Delete item "confirm" only works in Firefox
Status: RESOLVED DUPLICATE of bug 13943
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-21 04:31 UTC by David Cook
Modified: 2015-04-21 06:03 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Cook 2015-04-21 04:31:59 UTC
If you go to "Edit Items" in the staff client, and then click on "Delete" in the first table cell, the confirm box will delete the item regardless of the option you choose. The "cancel" option is completely ignored in Chrome and IE, but not Firefox.

I know there are those among us who say that we should only ever use Firefox, but a lot of people use other browsers, especially Chrome. 

Although, honestly I'm surprised that I haven't encountered this before. 

I also can't fix it for all Chrome/Firefox/IE.

I've switched the inline "onclick" to a jQuery click handler and used "e.preventDefault()", which works in Chrome/Firefox... but not IE.

Which is weird, because it works on other sites in IE: http://api.jquery.com/event.preventdefault/

I'm fresh out of ideas at the moment, but perhaps I'll look at this one again eventually...
Comment 1 Katrin Fischer 2015-04-21 05:44:45 UTC
You will probably not want to hear this... but it can happen in Firefox too. I saw it in a screen sharing session using Firefox. (bug 13943)
Comment 2 David Cook 2015-04-21 05:47:31 UTC
Ok... I might be going mad. 

Now I try it and it works fine in IE and Chrome... I think the universe is trolling me today.
Comment 3 Katrin Fischer 2015-04-21 05:49:34 UTC
I think this is a valid and scary bug... we are just not able to track it down YET. The library could only show it to me once, but I did see it and they had it happen more often.
Comment 4 David Cook 2015-04-21 05:52:32 UTC
Bizarre. Reopening this because it apparently only happens sometimes!
Comment 5 David Cook 2015-04-21 05:52:45 UTC
Bizarre. Reopening this because it apparently only happens sometimes!
Comment 6 David Cook 2015-04-21 06:03:57 UTC
Marking this as a duplicate of Katrin's older bug which is more accurate.

*** This bug has been marked as a duplicate of bug 13943 ***