Bug 14038 - SQLHelper replacement - C4::Members::Search - nl-search.pl
Summary: SQLHelper replacement - C4::Members::Search - nl-search.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 12633
  Show dependency treegraph
 
Reported: 2015-04-22 08:18 UTC by Jonathan Druart
Modified: 2015-12-03 22:00 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14038: Make nl-search.pl not using C4::Members::Search (1.64 KB, patch)
2015-04-22 08:23 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14038: Make nl-search.pl not using C4::Members::Search (1.76 KB, patch)
2015-04-29 12:56 UTC, Magnus Enger
Details | Diff | Splinter Review
[PASSED QA] Bug 14038: Make nl-search.pl not using C4::Members::Search (1.83 KB, patch)
2015-04-29 20:45 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-04-22 08:18:36 UTC
members/nl-search.pl currently uses C4::Members::Search.
To get rid of SQLHelper, we should not use this subroutine anymore.
Comment 1 Jonathan Druart 2015-04-22 08:23:30 UTC Comment hidden (obsolete)
Comment 2 Magnus Enger 2015-04-29 12:56:18 UTC Comment hidden (obsolete)
Comment 3 Magnus Enger 2015-04-29 13:01:51 UTC
QA team: This patch can only really be tested by a Norwegian library system vendor, because you need all sorts of passwords and secret handshakes... I think what can be done is testing for regressions, e.g. that normal patron search works as expected with NorwegianPatronDBEnable = Disable.
Comment 4 Katrin Fischer 2015-04-29 20:45:19 UTC
Created attachment 38694 [details] [review]
[PASSED QA] Bug 14038: Make nl-search.pl not using C4::Members::Search

To get rid of SQLHelper, we should not use this C4::Members::Search anymore.

Test plan for Magnus :)
0/ Enable the pref you need to use the Norwegian national library card ft
1/ Go on the members/nl-search.pl page and search for patrons.
2/ Make sure you search by card number and by "social security number"

Signed-off-by: Magnus Enger <magnus@enger.priv.no>
Searching works the same with and without the patch. Thanks Jonathan!

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Katrin Fischer 2015-04-29 20:46:00 UTC
Code touched by this patch is specific to the Norwegian library card feature - no regressions found and trusting Magnus as a tester here (have to... ;) )
Comment 6 Tomás Cohen Arazi 2015-05-15 18:44:14 UTC
Patch pushed to master.

Thanks Jonathan!