Bug 14276 - Keep highlight on the active item in item editor
Summary: Keep highlight on the active item in item editor
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Marcel de Rooy
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 14161 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-26 14:02 UTC by Marcel de Rooy
Modified: 2016-12-05 21:23 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14276: Keep highlight on the active item in item editor (2.09 KB, patch)
2015-05-26 14:11 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 14276: Keep highlight on the active item in item editor (2.11 KB, patch)
2015-05-26 14:16 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 14276: Keep highlight on the active item in item editor (2.17 KB, patch)
2015-05-29 15:50 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2015-05-26 14:02:32 UTC
As reported on bug 12176, but moved on its own:
The highlight only works on even items.
This patch should resolve it.
Comment 1 Marcel de Rooy 2015-05-26 14:11:33 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2015-05-26 14:16:42 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-05-26 14:17:09 UTC
Thanks Marcel!
Comment 4 Marcel de Rooy 2015-05-26 14:20:58 UTC
(In reply to Jonathan Druart from comment #3)
> Thanks Marcel!

Same for you :)
Comment 5 Kyle M Hall 2015-05-29 15:50:20 UTC
Created attachment 39698 [details] [review]
[PASSED QA] Bug 14276: Keep highlight on the active item in item editor

The highlight only works on even items.
This patch should resolve it.

Test plan:
Edit biblio with multiple items.
Verify that the highlight is visible on the selected item you edit.
And that there is no highlight for a new item.

Signed-off-by: Jonathan Druart <jonathan.druart@koha-community.org>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 6 Tomás Cohen Arazi 2015-06-05 16:06:37 UTC
Patch pushed to master.

Thanks Marcel!
Comment 7 Chris Cormack 2015-06-07 08:46:52 UTC
Pushed to 3.20.x will be in 3.20.1
Comment 8 Katrin Fischer 2015-06-08 11:34:30 UTC
*** Bug 14161 has been marked as a duplicate of this bug. ***
Comment 9 Liz Rea 2015-06-22 22:42:44 UTC
Patch pushed to 3.18.x will be in 3.18.08
Comment 10 Mason James 2015-07-25 10:10:06 UTC
Pushed to 3.16.x, will be in 3.16.13