Bug 14301 - “No renewal before” does not accept 0 as parameter.
Summary: “No renewal before” does not accept 0 as parameter.
Status: RESOLVED DUPLICATE of bug 14101
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-30 20:33 UTC by Claudio
Modified: 2015-06-03 11:44 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
“No renewal before” (106.24 KB, application/pdf)
2015-05-30 20:34 UTC, Claudio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio 2015-05-30 20:33:06 UTC
CIRCULATION AND FINE RULES: “No renewal before” does not accept 0 as parameter. Setting this parameter to 0  could enable issue due date as the only date to renew issues

Explanation attached.
Comment 1 Claudio 2015-05-30 20:34:52 UTC
Created attachment 39705 [details]
“No renewal before”
Comment 2 Claudio 2015-05-30 20:36:04 UTC
Tested in 3.18.* and 3.20
Comment 3 Katrin Fischer 2015-05-31 13:20:26 UTC
This sounds similar to what we discussed on bug 14101 - linking both bugs together for now.
Comment 4 Claudio 2015-05-31 14:46:03 UTC
(In reply to Katrin Fischer from comment #3)
> This sounds similar to what we discussed on bug 14101 - linking both bugs
> together for now.

Hi Katrin!

I'd like to contribute with a comment:

As I understand the problem "no renewal before" is independent from "auto_renew". 

1) First of all Koha should look for "auto_renew" conditions and apply them if they are true
2) THEN Koha should look for "no renewal before" conditions.

"no renewal before" only forces patrons and staff to renew issues in a range of days previous of the issue due-date. Imagine an issue that dues today may 31. If "no renewal before" is set to 1 it means that renewals are allowed on days 31 and 30; if it is set to 2 renewals are allowed on days 31, 30 and 29. But in this schema, which is the current schema, it is not possible to set "no renewal before" to 0. Setting "no renewal before" to 0 would enable renewals to be update only for due-date. 

So, the problem resides in how Koha calculates the enabled range of dates to renew the issues. Therefore it is independent from "auto_renew".

( Overriding this function in staff intranet works fine now. )
Comment 5 Holger Meißner 2015-06-03 11:30:25 UTC

*** This bug has been marked as a duplicate of bug 14101 ***
Comment 6 Holger Meißner 2015-06-03 11:44:58 UTC
Hi bondiurbano,

I have uploaded a patch to fix the problem with bug 14101. Please test and let me know if it works for you.

I also uploaded a table to illustrate how automatic renewals and 'No renewal before' work at this moment. If you have any suggestions for further changes please comment.